aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-02-17 07:25:49 +0200
committerStefan Strogin <steils@gentoo.org>2020-02-17 07:25:49 +0200
commitc339f870849cbf8dfe0c08e8da229ea7d1175b4a (patch)
tree597ec672eac6f0a066e20fff10d32d0703442343 /net-im
parentnet-im/riot-web: add USE=emoji to metadata.xml (diff)
downloadmatrix-c339f870849cbf8dfe0c08e8da229ea7d1175b4a.tar.gz
matrix-c339f870849cbf8dfe0c08e8da229ea7d1175b4a.tar.bz2
matrix-c339f870849cbf8dfe0c08e8da229ea7d1175b4a.zip
net-im/riot-web: version bump to 1.5.8
EAPI=7; some improvements. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Manifest-Sign-Key: 91F506E98D72366FB7DC330C1D6CD43295C97B7E Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/riot-web/Manifest20
-rw-r--r--net-im/riot-web/riot-web-1.5.8.ebuild86
2 files changed, 106 insertions, 0 deletions
diff --git a/net-im/riot-web/Manifest b/net-im/riot-web/Manifest
index 3faddd9..75b8634 100644
--- a/net-im/riot-web/Manifest
+++ b/net-im/riot-web/Manifest
@@ -1 +1,21 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
DIST riot-web-1.5.5.tar.gz 1518996 BLAKE2B ba355b75288de80b730ec2170d4841b394d0794e128eeb5de8185625a661729f051be0a2ac49e5babdea848f8a0064a3c414bb5f9e32bf760998e407c731cd70 SHA512 b8d147bd3220b842438feee1aa0bb49a223cad76d1848971ff685087945c79b170f2336119900586d2eb1e7f766738e4b3e544f6c646fae886f4ef7ff29328c7
+DIST riot-web-1.5.8.tar.gz 1396973 BLAKE2B db5bc568692c1d412c29e1b9f5cca9e0c24f1ba3f5cc4d320c182d8a40eb94c01bc5375488fa4656363482c6037baa12210d999b6fe8f457c1edbcdd4f086ac9 SHA512 e286e7eaa13696eb816170f462d5e0bc7cbbc4fee742b259e8d3b729fcedf4d4b133c1d7f11ad471d96cb429b74a8da683a74e97e5fe152ee97a4cc0ef01b76e
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAEBCAAdFiEEn50nOeJ3BmeaU7+oybpFp0RUBU0FAl5KI9oACgkQybpFp0RU
+BU1gwA/+MAVU+tfZp/k8pI02m8BgVDmROBTjiUta+2DIvugPU1VPjpIoHf3hpze3
+EJeU2cUWAZwmmnmOoKJRH0swqIPdcQ66mxmrUQzrmdbWdgJoLqbLdL0hurM49h4Z
+4l2z2xFSz/66yJhASl6mMJSjUIR5p9iyiKPRy+c1mTXYx1MjjTesa36mECkdqp1C
+NDUZCzpc20cUCL+m/zUb6KT66FmBQ5R2/G02i07fIVWudI7pMEHe9E32OGQkLQqe
+sVjCCY5yMzb80o847FALrQf97jO5z3H+1TCqT0G1HdIevVKfaWAWcUuWNJxL+VvS
+WZXpoecPXDBMfyCmhbUijE69OxZX/hrtjSwldJcdl/+/9w6Vm0bYL0Poxf536RoI
+12wfy5E2D6+1Tczxct/VKOuxdpuOyH72fr+MvVtQlGbTKPeMQpELuOd+/s6QbUz6
+MAvD7ZkASGDZ+IT3k1qB9yrs67jK0i8OzWpumP9N26G2sJmTNTFpoE3KeXdkjRrR
+tc/V2BcfXGfL4OMM1PRdDsb98rPZE/OCEtYdhLHXdkq8YXtGuvmbKOUVKV+KaDUU
+z5Jf5OmLC5sKA8U2yRiAym4F4aeON+tLO3I6EAkp4ZslIUcbFpxIa5MXkKbRs5Em
+NEgpBYsoeSKzyTPOn+xY55+jKaI1xNjfiM8yU+g8XrrwRAwOwaU=
+=XHMM
+-----END PGP SIGNATURE-----
diff --git a/net-im/riot-web/riot-web-1.5.8.ebuild b/net-im/riot-web/riot-web-1.5.8.ebuild
new file mode 100644
index 0000000..a5fd087
--- /dev/null
+++ b/net-im/riot-web/riot-web-1.5.8.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A glossy Matrix collaboration client for the web"
+HOMEPAGE="https://riot.im"
+
+inherit unpacker xdg-utils
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/vector-im/riot-web.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/vector-im/riot-web/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+emoji"
+REQUIRED_USE=""
+
+DEPEND="sys-devel/binutils:*
+ >=net-libs/nodejs-12.14.0
+ sys-apps/yarn
+ x11-libs/libXScrnSaver
+ net-print/cups
+ dev-libs/nss
+ gnome-base/gconf
+ emoji? ( >=media-fonts/noto-emoji-20180823 )"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="
+ opt/Riot/chrome-sandbox
+ opt/Riot/libGLESv2.so
+ opt/Riot/libEGL.so
+ opt/Riot/libffmpeg.so
+ opt/Riot/libnode.so
+ opt/Riot/riot-web
+ opt/Riot/swiftshader/libGLESv2.so
+ opt/Riot/swiftshader/libEGL.so
+ opt/Riot/swiftshader/libvk_swiftshader.so"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == "9999" ]]; then
+ "${S}"/scripts/fetch-develop.deps.sh
+ fi
+
+ yarn install || die "Yarn module installation failed"
+
+ cp "${S}"/config.sample.json "${S}"/config.json || die
+}
+
+src_compile() {
+ yarn run build || die "Build failed"
+
+ "${S}"/node_modules/.bin/electron-builder --linux --x64 || die "Bundling failed"
+}
+
+src_install() {
+ unpack electron_app/dist/riot-web*.deb
+ tar xvf data.tar.xz || die
+
+ mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ insinto /
+ doins -r usr
+ doins -r opt
+ fperms +x /opt/Riot/${PN}
+ dosym ../../opt/Riot/${PN} /usr/bin/${PN}
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}