aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-02-24 18:24:35 -0800
committerorbea <orbea@riseup.net>2024-02-24 18:24:35 -0800
commit8bc3b44e13ea00a73ab3019e5d7fa6b934aedb2c (patch)
treeee0ff01402ac895a07b4cd3c7baf377887362982 /net-libs
parentnet-libs/ldns: add 1.8.3-r2 (diff)
downloadlibressl-8bc3b44e13ea00a73ab3019e5d7fa6b934aedb2c.tar.gz
libressl-8bc3b44e13ea00a73ab3019e5d7fa6b934aedb2c.tar.bz2
libressl-8bc3b44e13ea00a73ab3019e5d7fa6b934aedb2c.zip
net-libs/ldns: drop 1.8.0-r4, 1.8.1, 1.8.3
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ldns/Manifest2
-rw-r--r--net-libs/ldns/ldns-1.8.0-r4.ebuild123
-rw-r--r--net-libs/ldns/ldns-1.8.1.ebuild93
-rw-r--r--net-libs/ldns/ldns-1.8.3.ebuild95
-rw-r--r--net-libs/ldns/metadata.xml7
5 files changed, 0 insertions, 320 deletions
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
index 9c2cbc3..ad02f5a 100644
--- a/net-libs/ldns/Manifest
+++ b/net-libs/ldns/Manifest
@@ -1,3 +1 @@
-DIST ldns-1.8.0.tar.gz 1283220 BLAKE2B f916a8c76d788ac7c52aea8bfe675ad4c614a0c6fb011b61f5a27d4a5dc1a2adb33b5c6992b4813b3758c9b7cceab1c77f8c1d66baaa4de993f23888bce69df1 SHA512 54b306160bb7fd76d181f4be0a13134017f6f98ae96e0c954409f31f262e9dbe611c4b76fb6dff47bb6155c652ed8d026b52a50dfcf611e54d9c204b314c4fd6
-DIST ldns-1.8.1.tar.gz 1284971 BLAKE2B ae01ef32571fe3996ddd41f911815239abb704ea1dee479fa612bfd701ca369222ab709923f014662248988cb4452a75bc5debad47d2b0386dc59169b353e6a3 SHA512 600f8e221716742caf439a425008827aef1814fc1d9e751f8f492d0235ff45ca48df90abba17979bac9f4485947bb9fe8102924d9cebe6cb56d5b788e1c4bd14
DIST ldns-1.8.3.tar.gz 1299856 BLAKE2B 2250445da3beec76c96fbb5cbc00f8d6a5bb6ed5867da7f23511d46ac73d6101303eb6ad85def426b7f9287f6a629a95117bcfa6eb46b775d07ed84048162c7f SHA512 c318747bd975ade389d048680b80495fb083b46507d8dcea7d4d42c75823f56a35b438dcc5320803d39583e5a1e515a51686f7f9010c061a6e8199e1a5505ae9
diff --git a/net-libs/ldns/ldns-1.8.0-r4.ebuild b/net-libs/ldns/ldns-1.8.0-r4.ebuild
deleted file mode 100644
index b48fefd..0000000
--- a/net-libs/ldns/ldns-1.8.0-r4.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9,10} )
-inherit python-single-r1 autotools multilib-minimal
-
-DESCRIPTION="A library with the aim to simplify DNS programming in C"
-HOMEPAGE="https://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="https://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/3"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+dane doc +ecdsa ed25519 ed448 examples gost python static-libs vim-syntax"
-
-# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-COMMON_DEPEND="
- python? ( ${PYTHON_DEPS} )
- >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}]
- examples? ( net-libs/libpcap )
-"
-DEPEND="${COMMON_DEPEND}
- python? ( dev-lang/swig )
- doc? ( app-text/doxygen )
-"
-RDEPEND="${COMMON_DEPEND}
- !<net-dns/ldns-utils-1.8.0-r2
-"
-
-RESTRICT="test" # 1.6.9 has no test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.7.1-libressl.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-multilib_src_configure() {
- # >=openssl-1.1.0 required for dane-ta
- if has_version "<dev-libs/openssl-1.1.0"; then
- local dane_ta_usage="--disable-dane-ta-usage"
- else
- local dane_ta_usage=""
- fi
-
- # "OpenSSL does not support offline DANE verification (Needed for the
- # DANE-TA usage type). Please upgrade OpenSSL to version >= 1.1.0 or rerun
- # with --disable-dane-verify or --disable-dane-ta-usage"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(use_enable gost) \
- $(use_enable ecdsa) \
- $(use_enable ed25519) \
- $(use_enable ed448) \
- $(use_enable dane) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --with-ssl="${EPREFIX}"/usr \
- --enable-sha2 \
- $(multilib_native_with drill) \
- $(multilib_native_use_with examples) \
- ${dane_ta_usage} \
- --disable-dane-ta-usage \
- --disable-rpath
-}
-
-src_prepare() {
- default
- # remove non-existing dependency for target packaging/libldns.pc
- sed -i 's,$(srcdir)/packaging/libldns.pc.in,,' "${S}"/Makefile.in || die 'could not patch Makefile.in'
-
- # remove $(srcdir) from path for multilib build
- sed -i 's,$(srcdir)/packaging/libldns.pc,packaging/libldns.pc,' "${S}"/Makefile.in || die 'could not patch Makefile.in'
-
- # remove Libs.private, see bug #695672
- sed -i '/^Libs.private:/d' "${S}"/packaging/libldns.pc.in || die 'could not patch libldns.pc.in'
-
- # backport https://github.com/NLnetLabs/ldns/commit/bc9d017f6fd8b6b5d2ff6e4489a2931d0aab8184
- sed -i 's/AC_SUBST(VERSION_INFO.*/AC_SUBST(VERSION_INFO, [5:0:2])/' "${S}"/configure.ac || die 'could not patch configure.ac'
-
- eautoreconf
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dodoc -r doc/html
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- find "${D}" -name '*.la' -delete || die
- use python && python_optimize
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
- fi
-}
diff --git a/net-libs/ldns/ldns-1.8.1.ebuild b/net-libs/ldns/ldns-1.8.1.ebuild
deleted file mode 100644
index 6d4c085..0000000
--- a/net-libs/ldns/ldns-1.8.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{9,10} )
-inherit python-single-r1 multilib-minimal
-
-DESCRIPTION="A library with the aim to simplify DNS programming in C"
-HOMEPAGE="https://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="https://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc examples python static-libs"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-BDEPEND="
- python? ( dev-lang/swig )
- doc? ( app-text/doxygen )
-"
-DEPEND="
- python? ( ${PYTHON_DEPS} )
- >=dev-libs/openssl-1.1.1l-r1:0=[${MULTILIB_USEDEP},static-libs?]
- examples? ( net-libs/libpcap )
-"
-RDEPEND="${DEPEND}
- !<net-dns/ldns-utils-1.8.0-r2
-"
-
-RESTRICT="test" # missing test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/ldns-1.7.1-libressl.patch"
- "${FILESDIR}/ldns-1.8.1-pkgconfig.patch"
- )
- default
-}
-
-multilib_src_configure() {
- # "OpenSSL does not support offline DANE verification (Needed for the
- # DANE-TA usage type). Please upgrade OpenSSL to version >= 1.1.0 or rerun
- # with --disable-dane-verify or --disable-dane-ta-usage"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --with-ssl="${EPREFIX}"/usr \
- $(multilib_native_with drill) \
- $(multilib_native_use_with examples) \
- --disable-dane-ta-usage \
- --disable-rpath
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dodoc -r doc/html
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- find "${D}" -name '*.la' -delete || die
- use python && python_optimize
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
-}
diff --git a/net-libs/ldns/ldns-1.8.3.ebuild b/net-libs/ldns/ldns-1.8.3.ebuild
deleted file mode 100644
index 6d7051a..0000000
--- a/net-libs/ldns/ldns-1.8.3.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9,10} )
-inherit autotools python-single-r1 multilib-minimal
-
-DESCRIPTION="A library with the aim to simplify DNS programming in C"
-HOMEPAGE="https://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="https://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc examples python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="test" # missing test directory
-
-BDEPEND="
- python? ( dev-lang/swig )
- doc? ( app-text/doxygen )
-"
-DEPEND="
- python? ( ${PYTHON_DEPS} )
- >=dev-libs/openssl-1.1.1l-r1:0=[${MULTILIB_USEDEP},static-libs?]
- examples? ( net-libs/libpcap )
-"
-RDEPEND="
- ${DEPEND}
- !<net-dns/ldns-utils-1.8.0-r2
-"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-PATCHES=(
- "${FILESDIR}/ldns-1.8.1-pkgconfig.patch"
- "${FILESDIR}/${P}-docs.patch"
- "${FILESDIR}/${P}-configure-strict.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Drop after 1.8.3
- eautoreconf
-}
-
-multilib_src_configure() {
- # "OpenSSL does not support offline DANE verification (Needed for the
- # DANE-TA usage type). Please upgrade OpenSSL to version >= 1.1.0 or rerun
- # with --disable-dane-verify or --disable-dane-ta-usage"
-
- ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --with-ssl="${EPREFIX}"/usr \
- $(multilib_native_with drill) \
- $(multilib_native_use_with examples) \
- --disable-dane-ta-usage \
- --disable-rpath
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dodoc -r doc/html
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- find "${D}" -name '*.la' -delete || die
- use python && python_optimize
-
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
-}
diff --git a/net-libs/ldns/metadata.xml b/net-libs/ldns/metadata.xml
index bea05fd..8fe7da4 100644
--- a/net-libs/ldns/metadata.xml
+++ b/net-libs/ldns/metadata.xml
@@ -11,13 +11,6 @@
level API which allows a programmer to (for instance) create or sign
packets.
</longdescription>
- <use>
- <flag name="dane">Enable DNS-based Authentication of Named Entities (DANE) support</flag>
- <flag name="ecdsa">Enable ECDSA support</flag>
- <flag name="ed25519">Enable ED25519 support</flag>
- <flag name="ed448">Enable ED448 support</flag>
- <flag name="gost">Enable GOST support</flag>
- </use>
<upstream>
<remote-id type="github">NLnetLabs/ldns</remote-id>
</upstream>