aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-06-21 06:20:07 -0700
committerorbea <orbea@riseup.net>2023-06-21 06:20:15 -0700
commit5a337f3015ff9536fd47d18da4e1c8ab70823382 (patch)
treedc58b60df17cc8382952413644bfee277f7eb208 /dev-perl
parentdev-perl/Net-SSLeay: use gentoo libressl patch (diff)
downloadlibressl-5a337f3015ff9536fd47d18da4e1c8ab70823382.tar.gz
libressl-5a337f3015ff9536fd47d18da4e1c8ab70823382.tar.bz2
libressl-5a337f3015ff9536fd47d18da4e1c8ab70823382.zip
dev-perl/Net-SSLeay: drop 1.920.0-r1
Bug: https://bugs.gentoo.org/903001 Upstream-PR: https://github.com/gentoo/gentoo/pull/31406 Upstream-Commit: https://github.com/gentoo/gentoo/commit/2cd8bce8727c9b68b8cbb3aa5fb6f2528a4db6d9 Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.920.0-r1.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.920.0-r1.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.920.0-r1.ebuild
deleted file mode 100644
index f91630c..0000000
--- a/dev-perl/Net-SSLeay/Net-SSLeay-1.920.0-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=CHRISN
-DIST_VERSION=1.92
-DIST_EXAMPLES=("examples/*")
-inherit perl-module
-
-DESCRIPTION="Perl extension for using OpenSSL"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="minimal examples"
-
-RDEPEND="
- dev-libs/openssl:=
- virtual/perl-MIME-Base64
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${RDEPEND}
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-File-Spec
- test? (
- !minimal? (
- dev-perl/Test-Exception
- dev-perl/Test-Warn
- dev-perl/Test-NoWarnings
- )
- virtual/perl-Test-Simple
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.88-fix-network-tests.patch"
- "${FILESDIR}/${PN}-1.92-libressl.patch" #903001
- "${FILESDIR}/${PN}-1.92-libressl-3.8.0.patch"
-)
-
-PERL_RM_FILES=(
- # Hateful author tests
- 't/local/01_pod.t'
- 't/local/02_pod_coverage.t'
- 't/local/kwalitee.t'
-)
-
-src_configure() {
- if use test && has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
- export NETWORK_TESTS=yes
- else
- use test && einfo "Network tests will be skipped without DIST_TEST_OVERRIDE=~network"
- export NETWORK_TESTS=no
- fi
- export LIBDIR=$(get_libdir)
- export OPENSSL_PREFIX="${ESYSROOT}/usr"
- perl-module_src_configure
-}
-
-src_compile() {
- mymake=(
- OPTIMIZE="${CFLAGS}"
- OPENSSL_PREFIX="${ESYSROOT}"/usr
- )
- perl-module_src_compile
-}