aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/persist-queue/Manifest1
-rw-r--r--dev-python/persist-queue/persist-queue-1.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/persist-queue/Manifest b/dev-python/persist-queue/Manifest
index dd8eb88c2..e5a396bf2 100644
--- a/dev-python/persist-queue/Manifest
+++ b/dev-python/persist-queue/Manifest
@@ -1 +1,2 @@
DIST persist-queue-0.8.1.tar.gz 29652 BLAKE2B b088a1d1784928e682151d0ccf984439df13b771aea4c5125b213a87fea05fbbc654fd80b787e141083a148b8b4b661b50fbe22f85cc582d0f411297089a88e2 SHA512 a5582deddd06108b4e748ee10fed5f64a328fe361b2db8f74400f7e43fc5800aafee67230e7edf481f926c8e20c73fb5d32109d15504a24caa67da848458ce6c
+DIST persist-queue-1.0.0.tar.gz 30262 BLAKE2B 266b731302ea4a805755df89ef62ad79f60d2b65a3b8f8acdb0daf9816e6a8f8a31f896f5757020f61403382612f00cbfee8d9ceea90782409c08bd8999162d9 SHA512 5fba323ca24dfe79688d2c89ac044729d4ef0b63d195d8fcac6da3ca5e6667d930c348626bce3cb808a560f06d0bfcad041be97b22811e7de0868324b3ef7c1b
diff --git a/dev-python/persist-queue/persist-queue-1.0.0.ebuild b/dev-python/persist-queue/persist-queue-1.0.0.ebuild
new file mode 100644
index 000000000..ed1002997
--- /dev/null
+++ b/dev-python/persist-queue/persist-queue-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A thread-safe disk based persistent queue in Python"
+HOMEPAGE="https://github.com/peter-wangxu/persist-queue"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It tries to connect to a local MySQL server
+RESTRICT="test"
+
+DEPEND="
+ dev-python/dbutils[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/pymysql[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"