aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mwclient/mwclient-0.10.1.ebuild')
-rw-r--r--dev-python/mwclient/mwclient-0.10.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mwclient/mwclient-0.10.1.ebuild b/dev-python/mwclient/mwclient-0.10.1.ebuild
new file mode 100644
index 000000000..a9dbb0a93
--- /dev/null
+++ b/dev-python/mwclient/mwclient-0.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright Gentoo Authors 2024
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{5..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unofficial lib for MediaWiki API"
+HOMEPAGE="
+ https://github.com/mwclient/mwclient
+ https://pypi.python.org/pypi/mwclient
+"
+SRC_URI="https://github.com/$PN/$PN/archive/refs/tags/v$PV.tar.gz -> $P.gh.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+"