aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/digitalocean')
-rw-r--r--dev-python/digitalocean/digitalocean-1.17.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/digitalocean/digitalocean-1.17.0-r1.ebuild b/dev-python/digitalocean/digitalocean-1.17.0-r1.ebuild
index 4d9fea2c0..1adcbf673 100644
--- a/dev-python/digitalocean/digitalocean-1.17.0-r1.ebuild
+++ b/dev-python/digitalocean/digitalocean-1.17.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Digitalocean API access library"
@@ -24,4 +24,9 @@ BDEPEND="test? ( dev-python/responses[${PYTHON_USEDEP}] )"
distutils_enable_sphinx docs dev-python/alabaster
+EPYTEST_DESELECT=(
+ # Needs net
+ digitalocean/tests/test_firewall.py
+)
+
distutils_enable_tests pytest