aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyPubSub/PyPubSub-4.0.3.ebuild')
-rw-r--r--dev-python/PyPubSub/PyPubSub-4.0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/PyPubSub/PyPubSub-4.0.3.ebuild b/dev-python/PyPubSub/PyPubSub-4.0.3.ebuild
new file mode 100644
index 000000000..0b0e1876e
--- /dev/null
+++ b/dev-python/PyPubSub/PyPubSub-4.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Forked from : https://data.gpo.zugaina.org/HomeAssistantRepository/dev-python/PyPubSub/PyPubSub-4.0.3.ebuild
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python Publish-Subscribe Package"
+HOMEPAGE="https://github.com/schollii/pypubsub https://pypi.org/project/PyPubSub/"
+MY_PN="pypubsub"
+SRC_URI="https://github.com/schollii/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DOCS="README.rst"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v -v || die
+}
+
+distutils_enable_tests pytest