aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/folly/folly-2021.11.15.00.ebuild')
-rw-r--r--dev-cpp/folly/folly-2021.11.15.00.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-cpp/folly/folly-2021.11.15.00.ebuild b/dev-cpp/folly/folly-2021.11.15.00.ebuild
new file mode 100644
index 000000000..d829bac72
--- /dev/null
+++ b/dev-cpp/folly/folly-2021.11.15.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="An open-source C++ library developed and used at Facebook"
+HOMEPAGE="https://github.com/facebook/folly"
+SRC_URI="https://github.com/facebook/folly/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ app-arch/lz4
+ <app-arch/snappy-1.1.9:=
+ app-arch/zstd
+ dev-cpp/gflags
+ dev-cpp/glog[gflags]
+ dev-libs/boost[context,threads(+)]
+ dev-libs/double-conversion
+ dev-libs/libevent
+ dev-libs/libfmt
+ sys-libs/binutils-libs
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ filter-flags "-fno-rtti"
+ cmake_src_prepare
+ sed \
+ -e "s/lib CACHE/$(get_libdir) CACHE/" \
+ -e "s/lib\/cmake\/folly CACHE/$(get_libdir)\/cmake\/folly CACHE/" \
+ -i CMakeLists.txt || die
+}