aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest-flask/Manifest2
-rw-r--r--dev-python/pytest-flask/pytest-flask-1.3.0.ebuild30
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/pytest-flask/Manifest b/dev-python/pytest-flask/Manifest
index fe3e97c59..2812cc719 100644
--- a/dev-python/pytest-flask/Manifest
+++ b/dev-python/pytest-flask/Manifest
@@ -1 +1 @@
-DIST pytest-flask-1.2.0.tar.gz 32446 BLAKE2B c0cbfdcf843573eba07cd009dc33b5f651dc859f94bd2059dccbf81ce6cc4c56870004b393254d9aa1beb5ff6225e3184ce26f71d74189eb6cb81b3ce0e3b219 SHA512 858ef198299f0cb5761bedcd98219fe8245abbd635630d6fe42f6b268db9029413c92cf163bc055387b0449cdcca695a1e7768cc3753c90f43373d8fa4e39e25
+DIST pytest-flask-1.3.0.tar.gz 35816 BLAKE2B 008c7f2acdc320dcab3e1745fb8e546a1f4cbdf75155db85f00bb70aea2eb3efa46d68f39fac114e3ddc3675b45d3d6d9a7bba8eb0c331c36e7f3d08c83c5da0 SHA512 4512e261cf6b284540ea9dda4cade52be57776c16f0cc7185755cbec294e526268753dbe663200a6ab3dee2ac0cc42df080d8f0045f88feac5de115fcc71ac21
diff --git a/dev-python/pytest-flask/pytest-flask-1.3.0.ebuild b/dev-python/pytest-flask/pytest-flask-1.3.0.ebuild
new file mode 100644
index 000000000..09aa38167
--- /dev/null
+++ b/dev-python/pytest-flask/pytest-flask-1.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{11,12} pypy3 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A set of pytest fixtures to test Flask applications "
+HOMEPAGE="http://pytest-flask.readthedocs.org"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest