aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/corrscope/corrscope-0.10.0-r1.ebuild (renamed from media-sound/corrscope/corrscope-0.10.0.ebuild)7
-rw-r--r--media-sound/corrscope/files/remove-npdeprecate.patch12
2 files changed, 18 insertions, 1 deletions
diff --git a/media-sound/corrscope/corrscope-0.10.0.ebuild b/media-sound/corrscope/corrscope-0.10.0-r1.ebuild
index ff81597e0..ea666260a 100644
--- a/media-sound/corrscope/corrscope-0.10.0.ebuild
+++ b/media-sound/corrscope/corrscope-0.10.0-r1.ebuild
@@ -4,7 +4,7 @@ EAPI=8
DISTUTILS_USE_PEP517=poetry
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -42,4 +42,9 @@ PATCHES=(
# Ideally, we should upstream a fix that only conditionally imports it,
# but I don't know how to do that right now.
"${FILESDIR}"/remove-appnope-dep.patch
+
+ # corrscope seems to have copied in a modified scipy file to their source
+ # tree. That file uses np.deprecate, which is removed in numpy2. corrscope
+ # doesn't care about this function being marked deprecated, so neither do we
+ "${FILESDIR}"/remove-npdeprecate.patch
)
diff --git a/media-sound/corrscope/files/remove-npdeprecate.patch b/media-sound/corrscope/files/remove-npdeprecate.patch
new file mode 100644
index 000000000..b165131e3
--- /dev/null
+++ b/media-sound/corrscope/files/remove-npdeprecate.patch
@@ -0,0 +1,12 @@
+diff --git a/corrscope/utils/scipy/windows.py b/corrscope/utils/scipy/windows.py
+index 0eee7f2..8ba1fa4 100644
+--- a/corrscope/utils/scipy/windows.py
++++ b/corrscope/utils/scipy/windows.py
+@@ -816,7 +816,6 @@ def hann(M: int, sym: bool = True) -> np.ndarray:
+ return general_hamming(M, 0.5, sym)
+
+
+-@np.deprecate(new_name='scipy.signal.windows.hann')
+ def hanning(*args, **kwargs):
+ return hann(*args, **kwargs)
+