aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorRoss Millen <rossmillen@protonmail.com>2022-10-24 11:05:11 +0100
committerRoss Millen <rossmillen@protonmail.com>2022-10-27 21:37:59 +0100
commitc16a4d352d18a053156085e1ad570b9783520339 (patch)
tree8a94d4992fee95dcbb30de60d3d18c6601a020fa /x11-wm
parentgui-apps/fuzzel: add 1.8.1, drop 1.8.0 (diff)
downloadguru-c16a4d352d18a053156085e1ad570b9783520339.tar.gz
guru-c16a4d352d18a053156085e1ad570b9783520339.tar.bz2
guru-c16a4d352d18a053156085e1ad570b9783520339.zip
x11-wm/berry: new package, add 0.1.12
Signed-off-by: Ross Millen <rossmillen@protonmail.com>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/berry/Manifest2
-rw-r--r--x11-wm/berry/berry-0.1.12.ebuild43
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-wm/berry/Manifest b/x11-wm/berry/Manifest
index d7c2e2650..69915e356 100644
--- a/x11-wm/berry/Manifest
+++ b/x11-wm/berry/Manifest
@@ -1 +1 @@
-DIST berry-0.1.11.tar.gz 29068 BLAKE2B 2df9f0003eaea6e3a94e4a4fee3161d8e6abbe6959b7774a370b08a20e6f341dd48045479b42c15cacf1faf06c0145b9d21158cd2aa1caf67e326a7b6fdb282e SHA512 6486c072f189017147d6996a44e0e3f58288fe12e42e794b625825135b4382177e884c86560b6f942d219cfa1106d86f44ab7cdab16f51a75971825e8b139129
+DIST berry-0.1.12.tar.gz 29340 BLAKE2B 597518ee632ddc57bd84507cec58d6671ac67691e7a0ceca0f77214e9afe86269d57dc6dbafba7c7283952a225a09edf3ac3795c170a2004da65ba98f8ffbbee SHA512 a186c125f9f1a7b359dedeadb4b627ffb7f9b641db35ef6cdbaf550095de12a9fc419539a00068eee32e46b9c8f5f65077aa4a74eb79c4b1d905d3822423c379
diff --git a/x11-wm/berry/berry-0.1.12.ebuild b/x11-wm/berry/berry-0.1.12.ebuild
new file mode 100644
index 000000000..d17302340
--- /dev/null
+++ b/x11-wm/berry/berry-0.1.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit toolchain-funcs
+
+DESCRIPTION="A byte-sized window manager written in C"
+HOMEPAGE="https://berrywm.org"
+SRC_URI="https://github.com/JLErvin/berry/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="examples"
+
+DEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/libXinerama
+ x11-libs/libX11
+ x11-libs/libXft
+"
+RDEPEND="${DEPEND}
+ x11-misc/sxhkd
+"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" DOCPREFIX="${EPREFIX}/usr/share/doc/${PF}" install
+
+ insinto /etc/xdg/sxhkd
+ doins examples/sxhkdrc
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+
+}