aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEthan Nijmeh <ethannij@gmail.com>2023-12-19 12:10:21 -0800
committerEthan Nijmeh <ethannij@gmail.com>2023-12-19 12:10:21 -0800
commit0699b68f4853b119d161178ff6f9dd49016572ea (patch)
treebae33ea8c63c8179376568b52d2cd10c8a0f5276 /x11-drivers
parentdev-python/aiomysql: remove setuptools_scm_git_archive BDEPEND (diff)
downloadguru-0699b68f4853b119d161178ff6f9dd49016572ea.tar.gz
guru-0699b68f4853b119d161178ff6f9dd49016572ea.tar.bz2
guru-0699b68f4853b119d161178ff6f9dd49016572ea.zip
x11-drivers/OpenTabletDriver-bin: new package, add 0.6.3.0
Signed-off-by: Ethan Nijmeh <ethannij@gmail.com>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/OpenTabletDriver-bin/Manifest5
-rw-r--r--x11-drivers/OpenTabletDriver-bin/OpenTabletDriver-bin-0.6.3.0.ebuild91
-rw-r--r--x11-drivers/OpenTabletDriver-bin/files/opentabletdriver.8166
-rwxr-xr-xx11-drivers/OpenTabletDriver-bin/files/otd-daemon3
4 files changed, 261 insertions, 4 deletions
diff --git a/x11-drivers/OpenTabletDriver-bin/Manifest b/x11-drivers/OpenTabletDriver-bin/Manifest
index 886495ae7..669552ce5 100644
--- a/x11-drivers/OpenTabletDriver-bin/Manifest
+++ b/x11-drivers/OpenTabletDriver-bin/Manifest
@@ -1,4 +1 @@
-DIST OpenTabletDriver-source-0.6.0.2.tar.gz 247519 BLAKE2B a84db9d7e1d86e8b6bf90231187800e4fb355c66e1c9e732a9e3687de0afeaeb0d69f397b5d3387bdb7a1e88393ddb26bb6c0d2920fa8d1ca51bc9992a818dae SHA512 0414a033e5bf3c5498676433502d44deb320d69a26823a1c731ab750c8ba71a3ff5af31662255e0c6c45e4d17f3009500e0a87967ca132bf309cf006cdb640b3
-DIST OpenTabletDriver-source-0.6.0.4.tar.gz 256483 BLAKE2B 5d6377f0591ac35d0e2e7b516efc76dbeb3737d37eae3bd38b19cbfe54c62bf4c98a3ba4b0ec60d3fcbdf4ed70493ca107cdfa8b8c728f1b04d12c1492661a71 SHA512 7b16f49c56f97ce8342b91ab92f96a5a7aad9ac2deba13b0fe93ef299d9c9404743d4c6c791a72a4dfbf3b96e0fb07bf98d91d1b5fe23b334a8b671b7ec7bb58
-DIST OpenTabletDriver-v0.6.0.2.tar.gz 4199076 BLAKE2B 754822c707388e8ac3c79a829ad67edad766381e4dcf96728b2f74e908daea1d7fb90b47ee3a922326cbf87ddd2a615ac1a85ca37d36ec7938b22c9f7c58d82e SHA512 0ff63e94ce36d4afc7d8862ee51c0444e734640b9ae468e733231dbfc3ecdcd6cf90f0128a0be1934a64ee79f0c5860a0812681537d4d9e1b478581a7c2acc22
-DIST OpenTabletDriver-v0.6.0.4.tar.gz 4208336 BLAKE2B b22f980fcd2e684d3fe109e0282cc6c10b1320a01a14de6268305c925ef9f2780d311913bae78304c6e2d281e30d29252581262d99cb6f77db5b1fe65212c090 SHA512 4b1978edc0ec9e47b809b7f2528c4bde6417205339f92a2e2f3007aa74a682e5a9f47770be92ad8ad91df3ef0222622961fc8553cfaf4c8201f05e750e992929
+DIST OpenTabletDriver-v0.6.3.0.tar.gz 8159234 BLAKE2B 206ef040fdcbc7a54a3b5ae474f545719453214d2f86c648064fcfdfc6d5a2cd0540f88343344c3995a151cf57d3e840cec2f6d68f1e04c9db2ea2c3ba98a55f SHA512 f9993e69fd11f83ccab4f2f310bf278c083d9b2b2737901e0b1c21c42a6233b275aafae2dcf24189d98b6a9d4b09ff1f9a904ccc2d87102a47fdecd02a3f96f2
diff --git a/x11-drivers/OpenTabletDriver-bin/OpenTabletDriver-bin-0.6.3.0.ebuild b/x11-drivers/OpenTabletDriver-bin/OpenTabletDriver-bin-0.6.3.0.ebuild
new file mode 100644
index 000000000..278abe385
--- /dev/null
+++ b/x11-drivers/OpenTabletDriver-bin/OpenTabletDriver-bin-0.6.3.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop udev
+
+MY_PN=OpenTabletDriver
+
+DESCRIPTION="Cross platform tablet driver (binary package)"
+HOMEPAGE="https://github.com/OpenTabletDriver"
+#SRC_URI="https://github.com/OpenTabletDriver/OpenTabletDriver/archive/refs/tags/v${PV}.tar.gz -> OpenTabletDriver-source-${PV}.tar.gz https://github.com/OpenTabletDriver/OpenTabletDriver/releases/download/v${PV}/OpenTabletDriver.linux-x64.tar.gz -> OpenTabletDriver-v${PV}.tar.gz"
+
+SRC_URI="https://github.com/OpenTabletDriver/OpenTabletDriver/releases/download/v0.6.3.0/opentabletdriver-0.6.3.0-x64.tar.gz -> OpenTabletDriver-v${PV}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr
+ dev-libs/libevdev
+ x11-libs/gtk+:3
+ virtual/udev
+ virtual/libudev
+ dev-dotnet/dotnet-sdk-bin:6.0
+"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}/opentabletdriver"
+src_install() {
+ local LP=opentabletdriver
+ local SP="otd"
+
+ cd "${S}/usr/local/lib/${LP}" || die
+
+ exeinto "/usr/lib/${LP}"
+ exeopts -o root -Dm755
+
+ for bin in *.Daemon *.UX.Gtk *.Console; do
+ doexe "$bin"
+ done
+
+ #insinto "/usr/lib/${LP}"
+
+ #for bin in *.Daemon *.UX.Gtk *.Console; do
+ # doins "$bin"
+ #done
+
+
+ cd "${FILESDIR}" || die
+
+ exeinto "/usr/bin"
+ exeopts -o root -Dm755
+
+ for binary in otd*; do
+ doexe "$binary"
+ done
+
+ cd "${S}/usr/local/share" || die
+
+ insinto "/usr/share"
+ doins -r "applications"
+ dodoc -r "doc"
+ doman "${FILESDIR}/opentabletdriver.8"
+ doins -r "pixmaps"
+ doicon "pixmaps/otd.png"
+
+ cd "${S}/etc/udev/rules.d" || die
+
+ insinto "/lib/udev/rules.d"
+ doins -r "70-opentabletdriver.rules"
+
+ make_desktop_entry /usr/local/bin/otd-gui OpenTabletDriver otd Settings
+}
+
+pkg_postrm() {
+ udev_reload
+}
+
+pkg_postinst() {
+ udev_reload
+ udevadm control --reload || die
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please replug your tablet before attempting to use the driver"
+ fi
+}
diff --git a/x11-drivers/OpenTabletDriver-bin/files/opentabletdriver.8 b/x11-drivers/OpenTabletDriver-bin/files/opentabletdriver.8
new file mode 100644
index 000000000..278f5faf0
--- /dev/null
+++ b/x11-drivers/OpenTabletDriver-bin/files/opentabletdriver.8
@@ -0,0 +1,166 @@
+.TH OpenTabletDriver 8
+
+.Sh NAME
+
+.B opentabletdriver
+
+Open source, cross platform, user mode tablet driver.
+
+.SY
+.SH SYNOPSIS
+
+.B opentabletdriver
+.RB [OPTIONS]
+
+.YS
+
+.SH DESCRIPTION
+
+OpenTabletDriver is a cross platform, open source, user mode graphics
+tablet driver aiming for the highest compatibility in an easily
+configurable graphical user interface.
+
+.SH OPTIONS
+
+
+.SS Daemon Options
+
+(Relevant to the portable tarball installation - OpenTabletDriver daemon when
+installed via package manager is launched by systemd or equivalent)
+
+.OP "-a, --appdata <directory>"
+
+Manually specify application data directory, defaults to
+~/.config/OpenTabletDriver/
+
+.OP "-c, --config <directory>"
+
+Manually specify configuration directory (location of JSON files used
+to recognize tablets)
+
+.OP "--version"
+
+Show version information
+
+.OP "-?, -h, --help"
+
+Show help and usage information
+
+.SS Graphical Front-end Options
+
+(Relevant to the package manager installation, opentabletdriver
+command will take these arguments for manipulating the GUI)
+
+.OP "-m, --minimized"
+
+Start OpenTabletDriver minimized, if possible in the desktop environment installed
+
+.OP "--version"
+
+Show version information
+
+.OP "-?, -h, --help"
+
+Show help and usage information for the GUI
+
+
+.SH DIAGNOSTICS
+
+The daemon log is created in the application data directory, at
+
+~/.config/OpenTabletDriver/daemon.log
+
+by default.
+
+
+.SH FREQUENT ISSUES AND QUESTIONS
+
+.SS Failed to open device streams
+
+This occurs due to a lack of permissions to open a device stream. It
+is resolved by creating udev rules that give these permissions. If you
+installed OpenTabletDriver via your package manager, you may need to
+run the following command then replug your tablet.
+
+.EX
+sudo udevadm control --reload-rules
+.EE
+
+.SS Poor performance with NVIDIA
+
+Disable "Force full composition pipeline" in the NVIDIA settings panel.
+
+
+.SS X11/Wayland Session not detected
+
+Your .xinitrc is likely configured improperly and the DISPLAY
+environment variable isn't set for systemd. Proper configuration for
+the .xinitrc file can be found at:
+
+.UR https://wiki.archlinux.org/index.php/Xinit#Configuration
+.UE
+
+.B For X11:
+
+1. Create an override file
+
+.EX
+# Opens with whatever program is set to $EDITOR
+systemctl --user edit opentabletdriver.service
+.EE
+
+2. Add this block below the first 2 lines of the file, then save and exit
+
+.EX
+[Service]
+Environment=DISPLAY=:0
+.EE
+
+3. Finally, run the following commands to reload the system user
+daemon and start the OpenTabletDriver daemon service, or restart it if it's already
+running:
+
+.EX
+systemctl --user daemon-reload
+systemctl --user restart opentabletdriver.service
+.EE
+
+.B For Wayland:
+
+1. Create an override file:
+
+.EX
+systemctl --user edit opentabletdriver.service
+.EE
+
+2. Add this block below the first 2 lines of the file, then save and exit
+
+.EX
+[Service]
+Environment=WAYLAND_DISPLAY=:0
+.EE
+
+3. Finally, run the following commands to reload the system user
+daemon and start the OpenTabletDriver daemon service, or restart it if it's already
+running:
+
+.EX
+systemctl --user daemon-reload
+systemctl --user restart opentabletdriver.service
+.EE
+
+.SS Failed to initialize virtual device
+
+.B EACCESS
+
+Run the following command:
+
+.EX
+sudo chmod 0666 /dev/uinput
+.EE
+
+.B ENODEV
+
+Rebooting is the only option here. Your kernel was very likely
+updated, or some component of uinput was modified which requires a
+reboot to resolve.
diff --git a/x11-drivers/OpenTabletDriver-bin/files/otd-daemon b/x11-drivers/OpenTabletDriver-bin/files/otd-daemon
new file mode 100755
index 000000000..9c3c7426c
--- /dev/null
+++ b/x11-drivers/OpenTabletDriver-bin/files/otd-daemon
@@ -0,0 +1,3 @@
+#!/usr/bin/env sh
+
+/usr/lib/opentabletdriver/OpenTabletDriver.Daemon "$@"