aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber@sysrq.in>2021-05-03 22:33:58 +0500
committerAnna Vyalkova <cyber@sysrq.in>2021-05-03 22:35:14 +0500
commit82b1c42abeded95e19e1e234770ae41f46591c15 (patch)
tree348b837b2caccafbd0185e51c7baf4742a5edf77 /www-servers
parentwww-client/browsh: add licenses for bundled .xpi (diff)
downloadguru-82b1c42abeded95e19e1e234770ae41f46591c15.tar.gz
guru-82b1c42abeded95e19e1e234770ae41f46591c15.tar.bz2
guru-82b1c42abeded95e19e1e234770ae41f46591c15.zip
www-servers/thin: fix failing tests and flags
Closes: https://bugs.gentoo.org/787827 Signed-off-by: Anna Vyalkova <cyber@sysrq.in>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/thin/thin-1.8.0.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/www-servers/thin/thin-1.8.0.ebuild b/www-servers/thin/thin-1.8.0.ebuild
index 3ea7476f7..9f43ab603 100644
--- a/www-servers/thin/thin-1.8.0.ebuild
+++ b/www-servers/thin/thin-1.8.0.ebuild
@@ -5,6 +5,10 @@ EAPI=7
USE_RUBY="ruby24 ruby25 ruby26"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
inherit ruby-fakegem
DESCRIPTION="This a Ruby gem that delivers a thin and fast web server"
@@ -22,8 +26,6 @@ ruby_add_depend "
dev-ruby/rack
"
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
all_ruby_prepare() {
# Fix Ragel-based parser generation (uses a *very* old syntax that
# is not supported in Gentoo)
@@ -49,8 +51,8 @@ all_ruby_prepare() {
-e '/tracing routines (with NO custom logger)/,/^ end/ s:^:#:'\
spec/logging_spec.rb || die
- find spec/perf -name "*_spec.rb" -exec \
- sed -i '/be_faster_then/ i \ pending' {} \;
+ # Remove failing perfomance tests
+ rm -r spec/perf || die
sed -i -e "s/Spec::Runner/Rspec/" spec/spec_helper.rb || die
# nasty but too complex to fix up for now :(
@@ -58,16 +60,16 @@ all_ruby_prepare() {
}
each_ruby_configure() {
- ${RUBY} -Cext/thin_parser extconf.rb || die
+ ${RUBY} -Cext/thin_parser extconf.rb || die
}
each_ruby_compile() {
- emake V=1 -Cext/thin_parser
- cp ext/thin_parser/thin_parser.so lib/ || die
+ emake V=1 CFLAGS="${CFLAGS} -fPIC" DLDFLAGS="${LDFLAGS}" -Cext/thin_parser
+ cp ext/thin_parser/thin_parser.so lib/ || die
}
all_ruby_install() {
- ruby_fakegem_binwrapper thin
+ ruby_fakegem_binwrapper thin
}
all_ruby_install() {