aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBailey Kasin <baileykasin@gmail.com>2023-11-01 18:34:20 -0700
committerBailey Kasin <baileykasin@gmail.com>2023-11-01 18:34:20 -0700
commite06882f0156717113609a6e4b4be4ac5241505c7 (patch)
treecd4ee86b3e891c476f1a221f198e7c772112e4a0 /www-apps
parentapp-misc/anki-bin: add 23.10, drop 2.1.66-r1 (diff)
downloadguru-e06882f0156717113609a6e4b4be4ac5241505c7.tar.gz
guru-e06882f0156717113609a6e4b4be4ac5241505c7.tar.bz2
guru-e06882f0156717113609a6e4b4be4ac5241505c7.zip
gpg --list-secret-keys --keyid-format=long
Signed-off-by: Bailey Kasin <baileykasin@gmail.com>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/whoogle-search/Manifest1
-rw-r--r--www-apps/whoogle-search/whoogle-search-0.8.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apps/whoogle-search/Manifest b/www-apps/whoogle-search/Manifest
index 08e76ab42..679442cc8 100644
--- a/www-apps/whoogle-search/Manifest
+++ b/www-apps/whoogle-search/Manifest
@@ -1 +1,2 @@
DIST v0.8.3.tar.gz 612951 BLAKE2B b413727cd3bf43646b4754fd7d3d55009ca7dff7601e4c28910347427719aa541da7cab544dcb6ff7f5fab8134e50a484790a5e8c46a06ac723b45eb39980bab SHA512 ea795435809d7b0e5c7860716ed05dfdc1e38b73fcbc6e4c482367cb03d2a84db48e619fb82520e3ef3041971ca9f35f0641b61a13dc4a68c9c38d9699c4182a
+DIST v0.8.4.tar.gz 616189 BLAKE2B 23c547d330b3b098eea4d63029ba109f8ecc0f4fefe031c77fcdb52d657aeb93d8d6fa3ae8f54ff9a7218c7c31aa1eccba57b333c376b92cc6a841f60cb14240 SHA512 6a9f7e7502253c2c6b72e8753595f4d57dca6fad2fceb1fece6e40203f7b85eb0ef7debda4852ed347b103ae89c1a188ccb989e56bc7c0ad81dccdda69dc2b58
diff --git a/www-apps/whoogle-search/whoogle-search-0.8.4.ebuild b/www-apps/whoogle-search/whoogle-search-0.8.4.ebuild
new file mode 100644
index 000000000..3ee914a88
--- /dev/null
+++ b/www-apps/whoogle-search/whoogle-search-0.8.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 systemd
+
+DESCRIPTION="A self-hosted, ad-free, privacy-respecting metasearch engine"
+HOMEPAGE="https://github.com/benbusby/whoogle-search"
+SRC_URI="https://github.com/benbusby/whoogle-search/archive/refs/tags/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cssutils[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ app-arch/brotli[${PYTHON_USEDEP},python]
+ net-libs/stem
+ acct-user/whoogle
+ acct-group/whoogle
+"
+
+
+src_install() {
+ rm -r .github docs test .dockerignore .gitignore .replit docker-compose.yml Dockerfile heroku.yml MANIFEST.in README.md requirements.txt
+ mkdir -p "${ED}/opt/whoogle-search" || die
+ insinto /opt/whoogle-search
+ doins -r ./*
+ fperms -R 0755 /opt/whoogle-search
+ fowners -R whoogle:whoogle /opt/whoogle-search
+
+ insinto /etc/default/
+ doins ${FILESDIR}/whoogle
+ insinto /usr/lib/sysusers.d/
+ doins ${FILESDIR}/whoogle.conf
+
+ systemd_dounit ${FILESDIR}/whoogle.service
+} \ No newline at end of file