aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-24 12:13:19 -0600
committerLeonardo Hernández Hernández <leohdz172@proton.me>2023-09-24 13:07:26 -0600
commit8d7b6237f5a5a9885497f1e7cc3eefcdcafeae04 (patch)
treea7ec0c51dc38eb561e48af59abe5392efb8c5fe4 /www-apps
parentgui-wm/dwl: add maintainer description (for myself) (diff)
downloadguru-8d7b6237f5a5a9885497f1e7cc3eefcdcafeae04.tar.gz
guru-8d7b6237f5a5a9885497f1e7cc3eefcdcafeae04.tar.bz2
guru-8d7b6237f5a5a9885497f1e7cc3eefcdcafeae04.zip
www-apps/code-server-bin: add 4.17.0
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/code-server-bin/Manifest2
-rw-r--r--www-apps/code-server-bin/code-server-bin-4.17.0.ebuild101
2 files changed, 103 insertions, 0 deletions
diff --git a/www-apps/code-server-bin/Manifest b/www-apps/code-server-bin/Manifest
index 09b661386..b8c06b52b 100644
--- a/www-apps/code-server-bin/Manifest
+++ b/www-apps/code-server-bin/Manifest
@@ -6,3 +6,5 @@ DIST code-server-4.16.0-linux-amd64.tar.gz 99495017 BLAKE2B 3d4afbc0d64bc31bd1ca
DIST code-server-4.16.0-linux-arm64.tar.gz 98257595 BLAKE2B 907cb8d0fd15e81eef3ed3cfa93018f289536cea480212424d89c90624dcd1bee3563008565fb8641fb2859989c211c1d1d791c42bf068e53bd43f71ecfa9eb5 SHA512 abc69af88743029d3bc2f1f4f7f2f46f671929f61dd193a531afba96bf678454b8ea0794709100aab5c6dbf86382bd9edb94582a2e6426219851e40e86bd489a
DIST code-server-bin-4.16.1-amd64.tar.gz 99495970 BLAKE2B 361c07e00ba297b2a901a133685b53d31e3804ce31c21b279619d61ae867c91261f8af9d1049a6467a87e5f355b32177207e68bdd970788e7ba8ac653deade6f SHA512 d0f657a6e1a455d8d5155174ac7700f5562513dccb816333286221d881346cbc837b3fdb1562966249535d975c017cd5f4f0dada2526517ad2622d945f2bd665
DIST code-server-bin-4.16.1-arm64.tar.gz 98260104 BLAKE2B bc889fdfe577b7115d2a6411354b915b3da02a1a22bdf576aba99ade9819a613ec76d4b26130d06c49e8e42eeb3e3fdf40a89b1910e43f3704761494d315f3d9 SHA512 f9bd711fe2334501bf339c2bed73a9411d898bf44dd34cf0ff7a476b74ae7397032186aca3c911321ce6808cecb3e67f244eee58a55a50ae9c62d9fe65b39c28
+DIST code-server-bin-4.17.0-amd64.tar.gz 96605967 BLAKE2B 631bb923170d4530596d313540df4f96fbd4c6ab481206de6106880772645d953731bec15b391201d9da5e87fb34350456f6301b7db4a2b4489c393bc82c53d8 SHA512 5b2d2ae4bef758364fa8080ac4fb6f60a2136d616f76ffe09e64de51c2046c5d3ff86425ce02d6cce32e91c0ceeb9391e3e86e2ef852db5c9b9a4cf8ba2b9d79
+DIST code-server-bin-4.17.0-arm64.tar.gz 95927302 BLAKE2B 8953ef7979eb35ddadc4238f631c385a2343fef93501e83387b6cb85575c5bb2dbbcd895bb11c0eb4ebf39980eebd4f93eef21881c1aa9c931605134e84a1df4 SHA512 6448e715a5541e38bf0bc75eafe6c2c5edc6e4628350531b0021139aaa40bd13dface37f79bad6009cd1932695468043953fede5507e9c7b6825ca7ae33c6f90
diff --git a/www-apps/code-server-bin/code-server-bin-4.17.0.ebuild b/www-apps/code-server-bin/code-server-bin-4.17.0.ebuild
new file mode 100644
index 000000000..56d038b6d
--- /dev/null
+++ b/www-apps/code-server-bin/code-server-bin-4.17.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/-bin/}"
+MY_P="${MY_PN}-${PV}"
+BASE_URI="https://github.com/coder/${MY_PN}/releases/download/v${PV}/${MY_P}-linux"
+
+inherit systemd
+
+DESCRIPTION="VS Code in the browser (binary version with unbundled node and ripgrep)"
+HOMEPAGE="https://coder.com/"
+SRC_URI="
+ amd64? ( ${BASE_URI}-amd64.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( ${BASE_URI}-arm64.tar.gz -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}/${MY_P}-linux-${ARCH}"
+
+LICENSE="MIT ISC BSD Apache-2.0 BSD-2 PYTHON 0BSD"
+LICENSE+=" LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+RESTRICT="test"
+
+RDEPEND="
+ app-crypt/libsecret
+ >=net-libs/nodejs-18.0.0[ssl]
+ sys-apps/ripgrep
+ virtual/krb5
+"
+
+PATCHES=( "${FILESDIR}/${PN}-node.patch" )
+
+DOCS=( README.md ThirdPartyNotices.txt )
+
+QA_PREBUILT="*"
+
+# Relative
+VSCODE_MODULES="lib/vscode/node_modules"
+QA_PRESTRIPPED="
+ opt/${PN}/node_modules/@node-rs/argon2-linux-x64-musl/argon2.linux-x64-musl.node
+ opt/${PN}/${VSCODE_MODULES}/@parcel/watcher/prebuilds/linux-x64/node.napi.musl.node
+ opt/${PN}/${VSCODE_MODULES}/@parcel/watcher/prebuilds/linux-x64/node.napi.glibc.node
+"
+
+src_prepare() {
+ default
+
+ # We remove as much precompiled code as we can,
+ # node modules not written in JS cannot be removed
+ # thus "-bin".
+
+ # use system node
+ rm ./lib/node || die "Failed to remove bundled nodejs"
+
+ # remove bundled ripgrep binary
+ rm ./"${VSCODE_MODULES}"/@vscode/ripgrep/bin/rg \
+ || die "Failed to remove bundled ripgrep"
+
+ # Only required at build time
+ find "${S}" -type l -name python3 -delete || die
+
+ # not needed
+ rm ./postinstall.sh || die
+
+ # For windows
+ rm -r ./"${VSCODE_MODULES}"/@parcel/watcher/prebuilds/win32-x64 || die
+
+ if [[ $ELIBC != "musl" ]]; then
+ rm ./"${VSCODE_MODULES}"/@parcel/watcher/prebuilds/linux-x64/node.napi.musl.node || die
+ elif [[ $ELIBC != "glibc" ]]; then
+ rm ./"${VSCODE_MODULES}"/@parcel/watcher/prebuilds/linux-x64/node.napi.glibc.node || die
+ rm ./"${VSCODE_MODULES}"/@parcel/watcher/prebuilds/darwin-x64/node.napi.glibc.node || die
+ rm ./"${VSCODE_MODULES}"/@parcel/watcher/prebuilds/darwin-arm64/node.napi.glibc.node || die
+ fi
+
+ rm -r ./lib/vscode/extensions/node_modules/.bin || die
+}
+
+src_install() {
+ einstalldocs
+
+ insinto "/opt/${PN}"
+ doins -r .
+ fperms +x "/opt/${PN}/bin/${MY_PN}"
+ dosym -r "/opt/${PN}/bin/${MY_PN}" "/opt/${PN}/bin/${PN}"
+ dosym -r "/opt/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dosym -r "/usr/bin/rg" \
+ "/opt/${PN}/${VSCODE_MODULES}/@vscode/ripgrep/bin/rg"
+
+ systemd_douserunit "${FILESDIR}/${PN}.service"
+ newinitd "${FILESDIR}/${PN}.rc" "${PN}"
+ newconfd "${FILESDIR}/${PN}.conf" "${PN}"
+}
+
+pkg_postinst() {
+ elog "When using code-server systemd service run it as a user"
+ elog "For example: 'systemctl --user enable --now code-server'"
+}