aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBailey Kasin <baileykasin@gmail.com>2023-09-02 00:16:10 -0700
committerBailey Kasin <baileykasin@gmail.com>2023-09-02 00:16:10 -0700
commit81c07fdabbd04cafc98c66a6003ecb9156eff08d (patch)
treec76c1f39c3aa0b5f3fc21a9293b48838ddc7adae /www-apps
parentacct-user/whoogle: new package, add 0 (diff)
downloadguru-81c07fdabbd04cafc98c66a6003ecb9156eff08d.tar.gz
guru-81c07fdabbd04cafc98c66a6003ecb9156eff08d.tar.bz2
guru-81c07fdabbd04cafc98c66a6003ecb9156eff08d.zip
www-apps/whoogle-search: new package, add 0.8.3
Signed-off-by: Bailey Kasin <baileykasin@gmail.com>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/whoogle-search/Manifest1
-rw-r--r--www-apps/whoogle-search/files/whoogle2
-rw-r--r--www-apps/whoogle-search/files/whoogle.conf1
-rw-r--r--www-apps/whoogle-search/files/whoogle.service18
-rw-r--r--www-apps/whoogle-search/metadata.xml8
-rw-r--r--www-apps/whoogle-search/whoogle-search-0.8.3.ebuild47
6 files changed, 77 insertions, 0 deletions
diff --git a/www-apps/whoogle-search/Manifest b/www-apps/whoogle-search/Manifest
new file mode 100644
index 000000000..08e76ab42
--- /dev/null
+++ b/www-apps/whoogle-search/Manifest
@@ -0,0 +1 @@
+DIST v0.8.3.tar.gz 612951 BLAKE2B b413727cd3bf43646b4754fd7d3d55009ca7dff7601e4c28910347427719aa541da7cab544dcb6ff7f5fab8134e50a484790a5e8c46a06ac723b45eb39980bab SHA512 ea795435809d7b0e5c7860716ed05dfdc1e38b73fcbc6e4c482367cb03d2a84db48e619fb82520e3ef3041971ca9f35f0641b61a13dc4a68c9c38d9699c4182a
diff --git a/www-apps/whoogle-search/files/whoogle b/www-apps/whoogle-search/files/whoogle
new file mode 100644
index 000000000..948dd3d40
--- /dev/null
+++ b/www-apps/whoogle-search/files/whoogle
@@ -0,0 +1,2 @@
+BIND_ADDRESS=127.0.0.1
+LISTEN_PORT=5000 \ No newline at end of file
diff --git a/www-apps/whoogle-search/files/whoogle.conf b/www-apps/whoogle-search/files/whoogle.conf
new file mode 100644
index 000000000..bdd57113d
--- /dev/null
+++ b/www-apps/whoogle-search/files/whoogle.conf
@@ -0,0 +1 @@
+u whoogle - "Whoogle" /opt/whoogle-search \ No newline at end of file
diff --git a/www-apps/whoogle-search/files/whoogle.service b/www-apps/whoogle-search/files/whoogle.service
new file mode 100644
index 000000000..950becae8
--- /dev/null
+++ b/www-apps/whoogle-search/files/whoogle.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Whoogle
+After=network-online.target
+Wants=network-online.target
+
+[Service]
+Type=simple
+User=whoogle
+WorkingDirectory=/opt/whoogle-search
+EnvironmentFile=/etc/default/whoogle
+ExecStart=/opt/whoogle-search/run
+ExecReload=/bin/kill -HUP $MAINPID
+Restart=always
+RestartSec=3
+SyslogIdentifier=whoogle
+
+[Install]
+WantedBy=multi-user.target \ No newline at end of file
diff --git a/www-apps/whoogle-search/metadata.xml b/www-apps/whoogle-search/metadata.xml
new file mode 100644
index 000000000..b3a874ebe
--- /dev/null
+++ b/www-apps/whoogle-search/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>baileykasin@gmail.com</email>
+ <name>Bailey Kasin</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-apps/whoogle-search/whoogle-search-0.8.3.ebuild b/www-apps/whoogle-search/whoogle-search-0.8.3.ebuild
new file mode 100644
index 000000000..3ee914a88
--- /dev/null
+++ b/www-apps/whoogle-search/whoogle-search-0.8.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 systemd
+
+DESCRIPTION="A self-hosted, ad-free, privacy-respecting metasearch engine"
+HOMEPAGE="https://github.com/benbusby/whoogle-search"
+SRC_URI="https://github.com/benbusby/whoogle-search/archive/refs/tags/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cssutils[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/waitress[${PYTHON_USEDEP}]
+ app-arch/brotli[${PYTHON_USEDEP},python]
+ net-libs/stem
+ acct-user/whoogle
+ acct-group/whoogle
+"
+
+
+src_install() {
+ rm -r .github docs test .dockerignore .gitignore .replit docker-compose.yml Dockerfile heroku.yml MANIFEST.in README.md requirements.txt
+ mkdir -p "${ED}/opt/whoogle-search" || die
+ insinto /opt/whoogle-search
+ doins -r ./*
+ fperms -R 0755 /opt/whoogle-search
+ fowners -R whoogle:whoogle /opt/whoogle-search
+
+ insinto /etc/default/
+ doins ${FILESDIR}/whoogle
+ insinto /usr/lib/sysusers.d/
+ doins ${FILESDIR}/whoogle.conf
+
+ systemd_dounit ${FILESDIR}/whoogle.service
+} \ No newline at end of file