aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-06-30 04:35:07 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-06-30 21:12:42 +0500
commitebe3ef7cf9659c75e57b23ce399ebe18fafae6a3 (patch)
tree1e8bc3cabe99653aeed9994c8be5a93f7baa63c7 /www-apps/castopod/castopod-1.4.3.ebuild
parentnet-misc/ooni-probe-cli: add 3.18.0, drop 3.17.3 (diff)
downloadguru-ebe3ef7cf9659c75e57b23ce399ebe18fafae6a3.tar.gz
guru-ebe3ef7cf9659c75e57b23ce399ebe18fafae6a3.tar.bz2
guru-ebe3ef7cf9659c75e57b23ce399ebe18fafae6a3.zip
www-apps/castopod: add 1.4.3
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'www-apps/castopod/castopod-1.4.3.ebuild')
-rw-r--r--www-apps/castopod/castopod-1.4.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/castopod/castopod-1.4.3.ebuild b/www-apps/castopod/castopod-1.4.3.ebuild
new file mode 100644
index 000000000..8505a433d
--- /dev/null
+++ b/www-apps/castopod/castopod-1.4.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature webapp
+
+UPLOAD_HASH="192f3a3fb2abba24fee6990c46ff0e2b"
+DESCRIPTION="Open-source hosting platform made for podcasters"
+HOMEPAGE="
+ https://castopod.org
+ https://code.castopod.org/adaures/castopod
+"
+SRC_URI="https://code.castopod.org/adaures/${PN}/uploads/${UPLOAD_HASH}/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3+ Apache-2.0 BSD-2 BSD GPL-1+ GPL-2 GPL-2+ GPL-3 LGPL-3 MIT MPL-2.0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-lang/php-8.1[curl,exif,gd,intl,mysqli,unicode,webp,xml]
+ virtual/httpd-php
+"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/writable
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ optfeature "better cache perfomance" dev-db/redis
+ optfeature "video clips support" media-video/ffmpeg
+}