aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2020-06-13 23:36:49 +0800
committerHuang Rui <vowstar@gmail.com>2020-06-13 23:36:49 +0800
commit7c9fb8355533da7ce8cd718b601528308056ee64 (patch)
tree0e59ac971d84fa9cb6395b946120f5bacd6cbaae /sys-process
parentsys-process/nvtop: change IUSE order and move CMAKE_CONF to local (diff)
downloadguru-7c9fb8355533da7ce8cd718b601528308056ee64.tar.gz
guru-7c9fb8355533da7ce8cd718b601528308056ee64.tar.bz2
guru-7c9fb8355533da7ce8cd718b601528308056ee64.zip
sys-process/nvtop: change IUSE order and move CMAKE_CONF to local
Optimize the ebuild file Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/nvtop/nvtop-1.0.0.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/sys-process/nvtop/nvtop-1.0.0.ebuild b/sys-process/nvtop/nvtop-1.0.0.ebuild
index 5d7ced8a6..b7b88afd9 100644
--- a/sys-process/nvtop/nvtop-1.0.0.ebuild
+++ b/sys-process/nvtop/nvtop-1.0.0.ebuild
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="unicode debug"
+IUSE="debug unicode"
RDEPEND="
sys-libs/ncurses:0=[unicode?]
@@ -32,20 +32,17 @@ BDEPEND="
virtual/pkgconfig
"
-BUILD_DIR="${WORKDIR}/build"
-
-CMAKE_CONF="
- !debug? ( -DCMAKE_BUILD_TYPE=Release )
- debug? ( -DCMAKE_BUILD_TYPE=Debug )
- unicode? ( -DCURSES_NEED_WIDE=TRUE )
-"
-
PATCHES=(
"${FILESDIR}"/${PN}-1.0.0-add-nvml.patch
"${FILESDIR}"/${PN}-1.0.0-fix-ncurses.patch
)
src_configure() {
+ local CMAKE_CONF="
+ !debug? ( -DCMAKE_BUILD_TYPE=Release )
+ debug? ( -DCMAKE_BUILD_TYPE=Debug )
+ unicode? ( -DCURSES_NEED_WIDE=TRUE )
+ "
local mycmakeargs=(
-DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
-DNVML_INCLUDE_DIRS="${S}/include"