aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2020-06-13 23:25:50 +0800
committerHuang Rui <vowstar@gmail.com>2020-06-13 23:28:06 +0800
commit795fa06d3a39031447bcc489912b3bc5ae814c05 (patch)
tree08a95dcea85441b1be037a5befdbbc0722576ebf /sys-process
parentsys-process/nvtop: new package (diff)
downloadguru-795fa06d3a39031447bcc489912b3bc5ae814c05.tar.gz
guru-795fa06d3a39031447bcc489912b3bc5ae814c05.tar.bz2
guru-795fa06d3a39031447bcc489912b3bc5ae814c05.zip
sys-process/nvtop: add live build
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Huang Rui <vowstar@gmail.com>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/nvtop/nvtop-9999.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-process/nvtop/nvtop-9999.ebuild b/sys-process/nvtop/nvtop-9999.ebuild
new file mode 100644
index 000000000..9ef08c840
--- /dev/null
+++ b/sys-process/nvtop/nvtop-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="NVIDIA GPUs htop like monitoring tool"
+HOMEPAGE="https://github.com/Syllo/nvtop"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Syllo/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Syllo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="unicode debug"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ x11-drivers/nvidia-drivers
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+BUILD_DIR="${WORKDIR}/build"
+
+CMAKE_CONF="
+ !debug? ( -DCMAKE_BUILD_TYPE=Release )
+ debug? ( -DCMAKE_BUILD_TYPE=Debug )
+ unicode? ( -DCURSES_NEED_WIDE=TRUE )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.0-add-nvml.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DNVML_INCLUDE_DIRS="${S}/include"
+ ${CMAKE_CONF}
+ )
+
+ cmake-utils_src_configure
+}