aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-05-09 10:39:36 -0500
committerZen <z@pyl.onl>2024-05-09 10:39:36 -0500
commit65f05aa979601a8271f08bdbcc47a677ff8be4df (patch)
treefa064b39e3a0a0a2e58b8c5b94eb569ccd84d485 /sys-kernel
parentnet-misc/warp: drop 0.6.2 (diff)
downloadguru-65f05aa979601a8271f08bdbcc47a677ff8be4df.tar.gz
guru-65f05aa979601a8271f08bdbcc47a677ff8be4df.tar.bz2
guru-65f05aa979601a8271f08bdbcc47a677ff8be4df.zip
sys-kernel/ugrd: Add 1.4.0
Signed-off-by: Zen <z@pyl.onl>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-1.4.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index af7adb76f..1a6154385 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -1,3 +1,4 @@
DIST ugrd-0.22.0.tar.gz 44444 BLAKE2B 01c4cc36ea778c12478b3b2f6db76180f9b7ef8d214b7cb2ab7579826f67d9166ac889ba17ae59819a3870cd2847b6ba4f8fff373dc670a4cde2a85dc60e2b67 SHA512 498b65070a83a810ec2c84bb58ca380f0836654f5ac2676bc358b5e80ea48057156102b3e1983695decdcffa64bd5bfe05df963d98342171c3e9c2906d9370da
DIST ugrd-1.2.2.tar.gz 49312 BLAKE2B 819457ae44cb278b93ef24af5e0aa2e23bf2d31d07fccec86e597f658a5cb13aad7838b08df644090417719402673b63087d27b6edbdb46dea04b98b48d26fb0 SHA512 6348458708406408973534ac5f15f8f9f6d9427bbac48443f7ff362bb97627be6288ba2d138355f92fc1c79a4eb5e51081485adb051cadf523a58f1ef618667e
DIST ugrd-1.3.8.tar.gz 50142 BLAKE2B 0a61977eb6c0fb6af31db445061385057acf825b4fd300aecda25b70a3ee0ce941c34a2c4d8a712e5d737c4aa2a01f0eb6e5e4dfabc4cd4436f343356d1890ea SHA512 95f5b9b2ea60409b6e5f33e813c7a5c4c8c2613c724b15d9a2b482fd8dd4eb59a209473cade9496fb901f633c3a06357a2cd9477cc3de1f2e2f759162065eb6e
+DIST ugrd-1.4.0.tar.gz 50372 BLAKE2B aa5b253d78f82d9a35d812d8090441e7c068c048530a5a4e27c6dd0e15d4e3c4b59582311043a5a55904b09c8468d2600c2548e32e1c918b5f7db45c367e9653 SHA512 020eaae8659f5143a63c122fe6f30ed48b231f96d8ae9eb4f3c2861684d9dbe8999fcc5d6d7fa68d473bd565089f96a36f3fa01c61f8113955eac2aef1f3fe2c
diff --git a/sys-kernel/ugrd/ugrd-1.4.0.ebuild b/sys-kernel/ugrd/ugrd-1.4.0.ebuild
new file mode 100644
index 000000000..8776e1384
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-1.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature shell-completion
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-misc/pax-utils
+ >=dev-python/zenlib-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pycpio-1.0.0[${PYTHON_USEDEP}]
+ sys-apps/pciutils
+"
+
+src_install() {
+ # Call the distutils-r1_src_install function to install the package
+ distutils-r1_src_install
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+ # Create the kernel preinst.d directory if it doesn't exist
+ # Install the kernel preinst.d hook
+ keepdir /etc/kernel/preinst.d
+ exeinto /etc/kernel/preinst.d
+ doexe hooks/51-ugrd.install
+ # Install bash autocomplete script
+ dobashcomp completion/ugrd
+ dozshcomp completion/_ugrd
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+}