aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-07 00:47:40 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-07 00:53:00 +0500
commit1e4f24ebb9980c6c6d6b9a9a7597e022332d343f (patch)
tree05c8c8cc7dce2d382bab8a968fc91a85bd0134d2 /sys-cluster
parentapp-admin/oet: Added metadata.xml (diff)
downloadguru-1e4f24ebb9980c6c6d6b9a9a7597e022332d343f.tar.gz
guru-1e4f24ebb9980c6c6d6b9a9a7597e022332d343f.tar.bz2
guru-1e4f24ebb9980c6c6d6b9a9a7597e022332d343f.zip
sys-cluster/OpenHPC-meta: remove scorep dep
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/OpenHPC-meta/OpenHPC-meta-2.1-r1.ebuild (renamed from sys-cluster/OpenHPC-meta/OpenHPC-meta-2.1.ebuild)42
1 files changed, 20 insertions, 22 deletions
diff --git a/sys-cluster/OpenHPC-meta/OpenHPC-meta-2.1.ebuild b/sys-cluster/OpenHPC-meta/OpenHPC-meta-2.1-r1.ebuild
index b347af749..a57bd0d5c 100644
--- a/sys-cluster/OpenHPC-meta/OpenHPC-meta-2.1.ebuild
+++ b/sys-cluster/OpenHPC-meta/OpenHPC-meta-2.1-r1.ebuild
@@ -1,33 +1,36 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..10} )
inherit python-single-r1
DESCRIPTION="OpenHPC metapackage"
-SLOT="0"
-LICENSE="GPL-2"
HOMEPAGE="
https://openhpc.community
https://github.com/openhpc/ohpc
"
+
KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="metapackage"
IUSE="+io-libs +parallel +perf-tools +python +runtimes +serial +slurm-client +slurm-server" #geopm warewulf
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
#TODO: add metis/partition useflags in a way that doesn't pull in non-free parmetis
RDEPEND="
${PYTHON_DEPS}
- || ( sys-libs/libunwind sys-libs/llvm-libunwind )
-
app-shells/pdsh
sys-apps/ipmitool
sys-process/numactl
virtual/mpi
-
+ || (
+ sys-libs/libunwind
+ sys-libs/llvm-libunwind
+ )
io-libs? (
sci-libs/hdf5[cxx,fortran,mpi]
sci-libs/netcdf[hdf5,mpi]
@@ -35,9 +38,12 @@ RDEPEND="
sci-libs/netcdf-fortran
sys-cluster/adios2[fortran,hdf5,mpi]
sys-cluster/parallel-netcdf
- python? ( $(python_gen_cond_dep 'sys-cluster/adios2[python,${PYTHON_SINGLE_USEDEP}]') )
+ python? (
+ $(python_gen_cond_dep '
+ sys-cluster/adios2[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
)
-
parallel? (
dev-libs/boost[mpi]
sci-libs/fftw[mpi]
@@ -51,16 +57,18 @@ RDEPEND="
sci-mathematics/petsc[fftw,hypre,mpi,mumps,scotch]
sci-mathematics/slepc[mpi]
sys-cluster/opencoarrays
-
io-libs? (
sci-libs/mfem[netcdf]
sci-libs/trilinos[hdf5,netcdf]
sci-mathematics/petsc[hdf5]
)
- python? ( $(python_gen_cond_dep 'dev-libs/boost[numpy,python,${PYTHON_USEDEP}]') )
+ python? (
+ $(python_gen_cond_dep '
+ dev-libs/boost[numpy,python,${PYTHON_USEDEP}]
+ ')
+ )
serial? ( sci-libs/mfem[superlu] )
)
-
perf-tools? (
dev-libs/papi
sys-apps/likwid
@@ -68,10 +76,7 @@ RDEPEND="
sys-cluster/extrae[${PYTHON_SINGLE_USEDEP}]
sys-cluster/mpi-benchmarks
sys-cluster/osu-micro-benchmarks
- sys-cluster/scalasca
- sys-cluster/scorep[mpi,unwind]
)
-
python? (
$(python_gen_cond_dep '
dev-python/mpi4py[${PYTHON_USEDEP}]
@@ -79,12 +84,10 @@ RDEPEND="
dev-python/scipy[${PYTHON_USEDEP}]
')
)
-
runtimes? (
sys-cluster/charliecloud[${PYTHON_SINGLE_USEDEP}]
app-containers/apptainer
)
-
serial? (
dev-lang/R[lapack]
sci-libs/gsl[cblas-external]
@@ -93,18 +96,15 @@ RDEPEND="
sci-libs/plasma
sci-libs/superlu
)
-
slurm-client? (
sys-apps/hwloc
sys-cluster/slurm[numa,pam]
io-libs? ( sys-cluster/slurm[hdf5] )
)
-
slurm-server? (
sys-cluster/slurm[numa,perl,slurmdbd]
io-libs? ( sys-cluster/slurm[hdf5] )
)
-
"
# perf-tools
#tau
@@ -128,5 +128,3 @@ RDEPEND="
#warewulf-provision-server
#warewulf-vnfs
#)
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"