aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2023-12-01 18:02:03 +0100
committerHenri Gasc <gasc@eurecom.fr>2023-12-01 21:50:03 +0100
commit28c97e1d0a06ed6317fdaa5e61fa2e9eb14952f2 (patch)
tree39ce5f041632b0acc14055c2cb5fbfdcd3dee348 /sci-mathematics
parentnet-im/discord-canary-bin: update 0.0.166 -> 0.0.203 (diff)
downloadguru-28c97e1d0a06ed6317fdaa5e61fa2e9eb14952f2.tar.gz
guru-28c97e1d0a06ed6317fdaa5e61fa2e9eb14952f2.tar.bz2
guru-28c97e1d0a06ed6317fdaa5e61fa2e9eb14952f2.zip
sci-mathematics/pyromaths: update HOMEPAGE and ebuild
Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild b/sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild
index b1980e1c9..0a7bd96a2 100644
--- a/sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild
+++ b/sci-mathematics/pyromaths/pyromaths-21.8.2.ebuild
@@ -1,17 +1,17 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1
DESCRIPTION="Create maths exercises in LaTeX and PDF format"
HOMEPAGE="
- https://www.pyromaths.org
+ https://pyromaths.frama.io/pyromaths-staticsite
https://pypi.org/project/pyromaths
https://framagit.org/pyromaths/pyromaths
"
@@ -21,10 +21,11 @@ S="${WORKDIR}/${PN}-version-${PV}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="test"
+IUSE="test doc"
RDEPEND="
dev-python/lxml[${PYTHON_USEDEP}]
+ dev-tex/latexmk
dev-texlive/texlive-pstricks
dev-texlive/texlive-basic
dev-texlive/texlive-latexextra
@@ -33,12 +34,13 @@ RDEPEND="
dev-texlive/texlive-mathscience
"
BDEPEND="
- dev-python/jinja2-cli
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-argparse[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/jinja2-cli[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-argparse[${PYTHON_USEDEP}]
+ )
"
-DEPEND="${RDEPEND} ${BDEPEND}"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/setuptools.patch"
@@ -48,10 +50,10 @@ distutils_enable_tests pytest
python_compile() {
distutils-r1_python_compile
- emake man -C Doc
+ use doc && emake man -C Doc
}
python_install() {
distutils-r1_python_install
- doman "${S}/Doc/build/man/pyromaths.1"
+ use doc && doman "${S}/Doc/build/man/pyromaths.1"
}