aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-01 13:06:28 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-06-02 03:23:29 +0200
commit473d4ede7e72f53122b8ab5bfb5df6a5cffda139 (patch)
tree6bd8209a4115054c7d50726be080716ea316ec4d /sci-libs
parentdev-ml/inotify: add 2.4 (diff)
downloadguru-473d4ede7e72f53122b8ab5bfb5df6a5cffda139.tar.gz
guru-473d4ede7e72f53122b8ab5bfb5df6a5cffda139.tar.bz2
guru-473d4ede7e72f53122b8ab5bfb5df6a5cffda139.zip
sci-libs/plasma: new package, add 21.8.29
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/plasma/Manifest1
-rw-r--r--sci-libs/plasma/metadata.xml15
-rw-r--r--sci-libs/plasma/plasma-21.8.29.ebuild54
3 files changed, 70 insertions, 0 deletions
diff --git a/sci-libs/plasma/Manifest b/sci-libs/plasma/Manifest
new file mode 100644
index 000000000..b805bc355
--- /dev/null
+++ b/sci-libs/plasma/Manifest
@@ -0,0 +1 @@
+DIST plasma-21.8.29.tar.gz 596586 BLAKE2B c41e8b86827ec0137b35bd882ae09acfdcf81f75dc45c17be79b2f08f237ce9c82c58fb4815f1c7b285df7ce9f7e3308d1fb7d0b5596dbb72d2583ccae9af8fd SHA512 4f56d4e31c2fdf52d4504856d3fb54f49f5f1b946e477a0125b24eabf11737064e81ba4fd87e6c3d480259e8a97bdcf13d7db2925a55e4a5ef595b2fbb94d684
diff --git a/sci-libs/plasma/metadata.xml b/sci-libs/plasma/metadata.xml
new file mode 100644
index 000000000..690a401a9
--- /dev/null
+++ b/sci-libs/plasma/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bitbucket.org/icl/plasma/issues</bugs-to>
+ <remote-id type="bitbucket">icl/plasma</remote-id>
+ <remote-id type="github">NLAFET/plasma</remote-id>
+ </upstream>
+ <longdescription lang="en">PLASMA is a software package for solving problems in dense linear algebra using OpenMP. PLASMA provides implementations of state-of-the-art algorithms using cutting-edge task scheduling techniques. PLASMA currently offers a collection of routines for solving linear systems of equations, least squares problems, eigenvalue problems, and singular value problems.</longdescription>
+ <!--<use><flag name="magma">Use magma as dependency</flag></use>-->
+</pkgmetadata>
diff --git a/sci-libs/plasma/plasma-21.8.29.ebuild b/sci-libs/plasma/plasma-21.8.29.ebuild
new file mode 100644
index 000000000..7ef115592
--- /dev/null
+++ b/sci-libs/plasma/plasma-21.8.29.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake edo python-any-r1
+
+DESCRIPTION="PLASMA parallel library for dense linear algebra"
+HOMEPAGE="
+ https://bitbucket.org/icl/plasma
+ https://github.com/NLAFET/plasma
+"
+SRC_URI="https://bitbucket.org/icl/plasma/downloads/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="BSD-2"
+SLOT="0"
+# TODO: magma (requires cuda)
+
+RDEPEND="
+ dev-lang/lua
+ virtual/blas
+ virtual/cblas
+ virtual/lapack
+ virtual/lapacke
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+DOCS=( README.md ChangeLog )
+
+src_prepare() {
+# edo rm -r tools/lua*
+ edo sed -e "s|DESTINATION lib|DESTINATION $(get_libdir)|g" -i CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPLASMA_DETECT_LUA=ON
+ -DPLASMA_DETECT_MAGMA=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ einstalldocs
+}