aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-07-07 18:15:39 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-07-07 18:15:39 +0200
commit3c59924fe7b52e8283ca758e208a52abb537a347 (patch)
treea7f778df38911c46f98faf4cd2dec5ff7efe1401 /sci-libs
parentdev-java/gluegen: redo the patch (diff)
downloadguru-3c59924fe7b52e8283ca758e208a52abb537a347.tar.gz
guru-3c59924fe7b52e8283ca758e208a52abb537a347.tar.bz2
guru-3c59924fe7b52e8283ca758e208a52abb537a347.zip
sci-libs/STRUMPACK: use upstream patch
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/STRUMPACK/STRUMPACK-6.3.1-r2.ebuild (renamed from sci-libs/STRUMPACK/STRUMPACK-6.3.1-r1.ebuild)10
-rw-r--r--sci-libs/STRUMPACK/files/STRUMPACK-6.3.1-multilib-was-not-respected.patch27
2 files changed, 28 insertions, 9 deletions
diff --git a/sci-libs/STRUMPACK/STRUMPACK-6.3.1-r1.ebuild b/sci-libs/STRUMPACK/STRUMPACK-6.3.1-r2.ebuild
index 742f7fc41..7f589b169 100644
--- a/sci-libs/STRUMPACK/STRUMPACK-6.3.1-r1.ebuild
+++ b/sci-libs/STRUMPACK/STRUMPACK-6.3.1-r2.ebuild
@@ -49,15 +49,7 @@ REQUIRED_USE="
# slate? ( mpi )
# magma? ( cuda )
DOCS=( README.md CHANGELOG SUPPORT )
-
-src_prepare() {
- sed \
- -e "s|LIBRARY DESTINATION lib|LIBRARY DESTINATION $(get_libdir)|g" \
- -e "s|lib/cmake|$(get_libdir)/cmake|g" \
- -i CMakeLists.txt \
- || die
- cmake_src_prepare
-}
+PATCHES=( "${FILESDIR}/${P}-multilib-was-not-respected.patch" )
src_configure() {
use combblas && append-cppflags '-I/usr/include/CombBLAS'
diff --git a/sci-libs/STRUMPACK/files/STRUMPACK-6.3.1-multilib-was-not-respected.patch b/sci-libs/STRUMPACK/files/STRUMPACK-6.3.1-multilib-was-not-respected.patch
new file mode 100644
index 000000000..b12ca27f0
--- /dev/null
+++ b/sci-libs/STRUMPACK/files/STRUMPACK-6.3.1-multilib-was-not-respected.patch
@@ -0,0 +1,27 @@
+From f4345f9ef6365d29634e12e42cd9040a1693e600 Mon Sep 17 00:00:00 2001
+From: Pieter Ghysels <pghysels@lbl.gov>
+Date: Fri, 24 Jun 2022 17:17:05 -0700
+Subject: [PATCH] multilib was not respected, see
+ https://github.com/pghysels/STRUMPACK/issues/65
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,6 +28,8 @@ include(CheckLibraryExists)
+ # include(CMakePushCheckState)
+ include(CheckCXXSourceCompiles)
+
++include(GNUInstallDirs)
++
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/Modules")
+
+ # figure out Fortran/C name mangling
+@@ -723,7 +725,8 @@ install(FILES
+ DESTINATION include)
+
+ install(TARGETS strumpack EXPORT STRUMPACKTargets
+- LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+
+ # export targets and all