aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorItai Ferber <itai@itaiferber.net>2024-06-24 11:49:22 -0400
committerItai Ferber <itai@itaiferber.net>2024-06-24 11:49:22 -0400
commitddadfc9f4d9cecd47a6c6599df83fb5d34f464bc (patch)
tree180cfb3fcfc1b79ca6322c8b6a238c18e745f63f /net-vpn
parentprofiles: mask vulnerable net-im/conduit versions (diff)
downloadguru-ddadfc9f4d9cecd47a6c6599df83fb5d34f464bc.tar.gz
guru-ddadfc9f4d9cecd47a6c6599df83fb5d34f464bc.tar.bz2
guru-ddadfc9f4d9cecd47a6c6599df83fb5d34f464bc.zip
net-vpn/mullvadvpn-app: add 2024.4_beta1
Signed-off-by: Itai Ferber <itai@itaiferber.net>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/mullvadvpn-app/Manifest1
-rw-r--r--net-vpn/mullvadvpn-app/metadata.xml1
-rw-r--r--net-vpn/mullvadvpn-app/mullvadvpn-app-2024.4_beta1.ebuild73
3 files changed, 74 insertions, 1 deletions
diff --git a/net-vpn/mullvadvpn-app/Manifest b/net-vpn/mullvadvpn-app/Manifest
index 3315713c9..a026738bd 100644
--- a/net-vpn/mullvadvpn-app/Manifest
+++ b/net-vpn/mullvadvpn-app/Manifest
@@ -1 +1,2 @@
DIST MullvadVPN-2024.3_x86_64.rpm 88010345 BLAKE2B 8335327427e3033eca1219f16e340b0a5e9aac399e1d54f9abd771a0c02a5a6451dff89af7d9bc977ef2aca744259e99ba5ada1014eae6a69c38c384d1762d03 SHA512 4feec0521cd3a52b7d3aa82f851694ff8a27ab63188d673d6ce8b62d5485acbd8eefc6d35f99da6c40c6b6fce0e9c735d121329d97589a6869138aafafd62fd9
+DIST MullvadVPN-2024.4-beta1_x86_64.rpm 90815893 BLAKE2B 276d5194f5588e204ea7a50a7c64b637300d72c1ff6f5eff8b76c842324a6ce1e815548a5e128ec536586e53ccc8b1333e3ba8383f97d4572a8c96b010896d5b SHA512 3ba9f4593db906f7ee48f121ba6e961f7f7e43e41fc6f5e5d49ceef9b66513cc59429900501561e90bf486bac57463d7a5add57792097bd0f1797ea71d320d2f
diff --git a/net-vpn/mullvadvpn-app/metadata.xml b/net-vpn/mullvadvpn-app/metadata.xml
index b9f59b27e..0ef47ce42 100644
--- a/net-vpn/mullvadvpn-app/metadata.xml
+++ b/net-vpn/mullvadvpn-app/metadata.xml
@@ -1,7 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
<upstream>
<remote-id type="github">mullvad/mullvadvpn-app</remote-id>
</upstream>
diff --git a/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.4_beta1.ebuild b/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.4_beta1.ebuild
new file mode 100644
index 000000000..e6ee527fe
--- /dev/null
+++ b/net-vpn/mullvadvpn-app/mullvadvpn-app-2024.4_beta1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop rpm systemd shell-completion xdg
+
+MYPV="${PV/_beta/-beta}"
+DESCRIPTION="Tool used to manage daemon setup"
+HOMEPAGE="https://github.com/mullvad/mullvadvpn-app https://mullvad.net/"
+SRC_URI="amd64? ( https://github.com/mullvad/mullvadvpn-app/releases/download/${MYPV}/MullvadVPN-${MYPV}_x86_64.rpm )"
+
+S="${WORKDIR}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RESTRICT="bindist mirror test strip"
+
+RDEPEND="
+ app-accessibility/at-spi2-core
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ x11-libs/gtk+
+ x11-libs/libdrm
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/pango
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ # Using doins -r would strip executable bits from all binaries
+ cp -pPR "${S}"/opt "${D}"/ || die "Failed to copy files"
+ fperms +x "/opt/Mullvad VPN/chrome_crashpad_handler"
+ fperms 4755 "/opt/Mullvad VPN/chrome-sandbox"
+
+ # tbh I don't know if all next lines are needed or we can just do cp -pPR "${S}"/usr "${D}"/"
+
+ local i
+ dobin "${S}"/usr/bin/mullvad
+ dobin "${S}"/usr/bin/mullvad-daemon
+ dobin "${S}"/usr/bin/mullvad-exclude
+ dosym "../../opt/Mullvad VPN/resources/mullvad-problem-report" /usr/bin/mullvad-problem-report
+
+ # mullvad-exclude uses cgroups to manage exclusions, which requires root permissions, but is
+ # also most often used to exclude graphical applications which can't or shouldn't run as root
+ # (i.e., can't be run under `sudo/doas /usr/bin/mullvad-exclude ...`, because `sudo`/`doas`
+ # change user). The setuid bit allows any user to exclude executables under their own UID.
+ fperms 4755 /usr/bin/mullvad-exclude
+
+ newinitd "${FILESDIR}"/mullvad-daemon.initd mullvad-daemon
+
+ systemd_newunit "${S}"/usr/lib/systemd/system/mullvad-daemon.service mullvad-daemon.service
+ systemd_newunit "${S}"/usr/lib/systemd/system/mullvad-early-boot-blocking.service mullvad-early-boot-blocking.service
+
+ newbashcomp "${S}"/usr/share/bash-completion/completions/mullvad mullvad
+ newfishcomp "${S}"/usr/share/fish/vendor_completions.d/mullvad.fish mullvad
+ newzshcomp "${S}"/usr/share/zsh/site-functions/_mullvad _mullvad
+
+ domenu "${S}"/usr/share/applications/mullvad-vpn.desktop
+ local x
+ for x in 16 32 48 64 128 256 512 1024; do
+ doicon -s ${x} "${S}"/usr/share/icons/hicolor/${x}x${x}/apps/mullvad-vpn.png
+ done
+}