aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-07-17 22:05:49 +0200
committerJonas Frei <freijon@pm.me>2023-07-17 22:05:49 +0200
commit46006b2d471cdb2e8330c8f50c5d6c77ab5cdbf4 (patch)
tree740196582ce8ee16597a59c9ef66ec281fe9cf2c /net-misc/curlie
parentgui-apps/wmenu: Add missing xkbcommon dependency (diff)
downloadguru-46006b2d471cdb2e8330c8f50c5d6c77ab5cdbf4.tar.gz
guru-46006b2d471cdb2e8330c8f50c5d6c77ab5cdbf4.tar.bz2
guru-46006b2d471cdb2e8330c8f50c5d6c77ab5cdbf4.zip
net-misc/curlie: new package, add 1.7.1
Signed-off-by: Jonas Frei <freijon@pm.me>
Diffstat (limited to 'net-misc/curlie')
-rw-r--r--net-misc/curlie/Manifest2
-rw-r--r--net-misc/curlie/curlie-1.7.1.ebuild37
-rw-r--r--net-misc/curlie/metadata.xml12
3 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/curlie/Manifest b/net-misc/curlie/Manifest
new file mode 100644
index 000000000..36a949413
--- /dev/null
+++ b/net-misc/curlie/Manifest
@@ -0,0 +1,2 @@
+DIST curlie-1.7.1-deps.tar.xz 24941764 BLAKE2B 9ca1ba1fdbff0f90eb85b7258ab0971bd81fe6562cbc2605b403bb168272690237ee62c21699414110a53474b71e31ce7bc14afc4fe1c427e664184f606bdb30 SHA512 3ac398c0c603e4b5d902cb2c66bdfb4a84212189adb15b6afc472233469fdc7c54bfe02596ee71e72ac8d38555cbf205d4c047b16ad09556179464dce601cf99
+DIST curlie-1.7.1.tar.gz 441925 BLAKE2B 74426e59072c9c811659eb02b7c4e3487a478687562714ae518bbe383d54d7974d071c475b1084b8ec18d86bf929323039e23adc6b747677dd3235a6e23d95bb SHA512 c2c1064b78814386694b28560aa154bc1b3cbe001797b325f47bed3139af3ca7c74af84801cf96c46dc7f3738c43416b93586d34674b7c531e87ba06b3e44f0e
diff --git a/net-misc/curlie/curlie-1.7.1.ebuild b/net-misc/curlie/curlie-1.7.1.ebuild
new file mode 100644
index 000000000..dca2e6376
--- /dev/null
+++ b/net-misc/curlie/curlie-1.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Curlie is a frontend to curl that adds the ease of use of httpie"
+HOMEPAGE="https://curlie.io/"
+SRC_URI="https://github.com/rs/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# Using a dependency tarball as per https://devmanual.gentoo.org/eclass-reference/go-module.eclass/index.html
+DEPS_URI="https://kdrive.infomaniak.com/2/app/192129/share/74ab6733-4354-4f97-84b5-8f270ff9e4f6/files/22/download -> ${P}-deps.tar.xz"
+SRC_URI+=" ${DEPS_URI}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ net-misc/curl
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/go
+"
+
+src_compile() {
+ ego build .
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc "README.md"
+ default
+}
diff --git a/net-misc/curlie/metadata.xml b/net-misc/curlie/metadata.xml
new file mode 100644
index 000000000..9a761d26f
--- /dev/null
+++ b/net-misc/curlie/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>freijon@pm.me</email>
+ <name>Jonas Frei</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rs/curlie</remote-id>
+ <bugs-to>https://github.com/rs/curlie/issues</bugs-to>
+ </upstream>
+</pkgmetadata>