aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-11-15 19:26:14 -0500
committerPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2024-11-15 19:26:14 -0500
commitd7c4dac49424055b1f90c86551b39faa819ec3ca (patch)
treea7845a6a9a4348b76bcf4b81264915fdf8f02d04 /net-mail
parentnet-mail/dovecot-fts-xapian: add 1.7.18 (diff)
downloadguru-d7c4dac49424055b1f90c86551b39faa819ec3ca.tar.gz
guru-d7c4dac49424055b1f90c86551b39faa819ec3ca.tar.bz2
guru-d7c4dac49424055b1f90c86551b39faa819ec3ca.zip
net-mail/dovecot-fts-xapian: add 1.8
Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dovecot-fts-xapian/Manifest1
-rw-r--r--net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.8.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-mail/dovecot-fts-xapian/Manifest b/net-mail/dovecot-fts-xapian/Manifest
index 26eff9578..f5cb0c26c 100644
--- a/net-mail/dovecot-fts-xapian/Manifest
+++ b/net-mail/dovecot-fts-xapian/Manifest
@@ -7,3 +7,4 @@ DIST dovecot-fts-xapian-1.7.17.tar.gz 35008 BLAKE2B 4b90b4193e6e62ce1c371f4f3818
DIST dovecot-fts-xapian-1.7.18.tar.gz 35160 BLAKE2B 67f11719336366a8460e3b67b90b4909626b73cface42b845c9efa8dfc5a5a24212c6ed48b8e575786d870c7b8b416936841fd6cc5b1ea078b2d0498db7ae735 SHA512 fed0947c0c7870ef0519359863becea822a51b9c76bc59c7100a7c9961b05740845a3ea5755fbb30e6d79869cb0f5b5b35e60675284ffecee088dfb54f0d5dfc
DIST dovecot-fts-xapian-1.7.6.tar.gz 36626 BLAKE2B 4112204e78fce042a4db5e6d3bd5d12e2ca6be8199ded4f7b3b7e0ff9977268491aa7e524f00103e1ee07d5ce0b59dcea171c5be19c7857dbeae9416c4fe984e SHA512 83b25bae097fceb56b62355cd8e10788bea850c2f312eb15fca72fb9c1d033d54e56c251eb27eeb971fe405da9d6a3509a3a700bbd0602d785949548ac15ba1f
DIST dovecot-fts-xapian-1.7.9.tar.gz 36884 BLAKE2B 6e2520a7b8a8250caa2a92af15e6eecdfbdbb542ff439e91baa0c084b3a6f6b02918decd0e0f0d888aba4db54b9566d63a796385a4d56970b69035845e20f84a SHA512 9df23186648902c9ca38f861496bff3e00005096be960a138b7d20eb3baff2734e16949614d1207cce34f2d6626634f58b35ea2c0500e2981f05eea1ad9da718
+DIST dovecot-fts-xapian-1.8.tar.gz 35196 BLAKE2B c30f2579ae168c18ff88e0b2dc65aec110a586a828ed69d5ec2a5b674af99c1dcb7525ac227522703b0a61491db5579e570cb5b8d9733403c978db7b2a0df0d8 SHA512 178922589ae307afbb465bdac9ba352c1198d4a97a204d190461751d0c117dad22119d964d8dbda2fb5f44a05f069536788a02e816a5822da28c8c96720c4a93
diff --git a/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.8.ebuild b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.8.ebuild
new file mode 100644
index 000000000..18a7328b4
--- /dev/null
+++ b/net-mail/dovecot-fts-xapian/dovecot-fts-xapian-1.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dovecot FTS plugin backed by Xapian"
+HOMEPAGE="https://github.com/grosjo/fts-xapian"
+SRC_URI="https://github.com/grosjo/fts-xapian/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/fts-xapian-${PV}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ >=dev-libs/xapian-1.4:=
+ net-mail/dovecot:=
+ dev-db/sqlite:*
+ "
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/bug-887887_allow-O2-override.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Disable hardening so CFLAGS are left up to the Gentoo user
+ # https://bugs.gentoo.org/888751
+ econf \
+ --enable-hardening=no \
+ --with-dovecot="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+ $( use_enable static-libs static )
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}