aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-12 12:46:05 +0530
committerRahil Bhimjiani <me@rahil.rocks>2024-03-12 12:46:05 +0530
commitc4cd203c0771fd29c52cd9914dea4de85afb4921 (patch)
treec24f7955d839e246b3a1cd81b8f57d3bf542878d /net-irc/thelounge
parentnet-irc/thelounge: setup for python only if +sqlite (diff)
downloadguru-c4cd203c0771fd29c52cd9914dea4de85afb4921.tar.gz
guru-c4cd203c0771fd29c52cd9914dea4de85afb4921.tar.bz2
guru-c4cd203c0771fd29c52cd9914dea4de85afb4921.zip
net-irc/thelounge: use python-any-r1 instead and tweak systemd unit
Upstream recommended to unset LimitNOFILE LimitNPROC Signed-off-by: Rahil Bhimjiani <me@rahil.rocks>
Diffstat (limited to 'net-irc/thelounge')
-rw-r--r--net-irc/thelounge/files/thelounge-4.4.1.service4
-rw-r--r--net-irc/thelounge/thelounge-4.4.1.ebuild7
-rw-r--r--net-irc/thelounge/thelounge-4.4.2_rc1.ebuild7
3 files changed, 6 insertions, 12 deletions
diff --git a/net-irc/thelounge/files/thelounge-4.4.1.service b/net-irc/thelounge/files/thelounge-4.4.1.service
index 125700086..78f9de379 100644
--- a/net-irc/thelounge/files/thelounge-4.4.1.service
+++ b/net-irc/thelounge/files/thelounge-4.4.1.service
@@ -36,9 +36,5 @@ NoNewPrivileges=true
ProtectSystem=strict
ReadWritePaths=/var/lib/%N
-# Set reasonable connection and process limits
-LimitNOFILE=1048576
-LimitNPROC=64
-
[Install]
WantedBy=multi-user.target
diff --git a/net-irc/thelounge/thelounge-4.4.1.ebuild b/net-irc/thelounge/thelounge-4.4.1.ebuild
index 096387d17..d83f68fd9 100644
--- a/net-irc/thelounge/thelounge-4.4.1.ebuild
+++ b/net-irc/thelounge/thelounge-4.4.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit python-single-r1 readme.gentoo-r1 systemd tmpfiles
+inherit python-any-r1 readme.gentoo-r1 systemd tmpfiles
DESCRIPTION="‎Modern, responsive, cross-platform, self-hosted web IRC client"
HOMEPAGE="https://thelounge.chat/"
@@ -21,7 +21,6 @@ LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+sqlite"
-REQUIRED_USE="sqlite? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
acct-user/${PN}
@@ -54,7 +53,7 @@ mooyarn() {
}
pkg_setup() {
- use sqlite && python-single-r1_pkg_setup
+ use sqlite && python-any-r1_pkg_setup
}
src_prepare() {
@@ -78,7 +77,7 @@ src_compile() {
export \
npm_config_cache="${WORKDIR}"/npm-cache \
npm_config_nodedir="${EPREFIX}"/usr \
- NODE_GYP_FORCE_PYTHON="$(command -v ${PYTHON_SINGLE_TARGET/_/.})" \
+ NODE_GYP_FORCE_PYTHON="${PYTHON}" \
|| die
npm --verbose --offline install --build-from-source --sqlite="${EPREFIX}"/usr || die
# sqlite3 cleanup
diff --git a/net-irc/thelounge/thelounge-4.4.2_rc1.ebuild b/net-irc/thelounge/thelounge-4.4.2_rc1.ebuild
index a8abb0005..cc14668af 100644
--- a/net-irc/thelounge/thelounge-4.4.2_rc1.ebuild
+++ b/net-irc/thelounge/thelounge-4.4.2_rc1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit python-single-r1 readme.gentoo-r1 systemd tmpfiles
+inherit python-any-r1 readme.gentoo-r1 systemd tmpfiles
DESCRIPTION="‎Modern, responsive, cross-platform, self-hosted web IRC client"
HOMEPAGE="https://thelounge.chat/"
@@ -21,7 +21,6 @@ LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+sqlite"
-REQUIRED_USE="sqlite? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
acct-user/${PN}
@@ -54,7 +53,7 @@ mooyarn() {
}
pkg_setup() {
- use sqlite && python-single-r1_pkg_setup
+ use sqlite && python-any-r1_pkg_setup
}
src_prepare() {
@@ -78,7 +77,7 @@ src_compile() {
export \
npm_config_cache="${WORKDIR}"/npm-cache \
npm_config_nodedir="${EPREFIX}"/usr \
- NODE_GYP_FORCE_PYTHON="$(command -v ${PYTHON_SINGLE_TARGET/_/.})" \
+ NODE_GYP_FORCE_PYTHON="${PYTHON}" \
|| die
npm --verbose --offline install --build-from-source --sqlite="${EPREFIX}"/usr || die
# sqlite3 cleanup