aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-16 23:59:23 -0500
committerJulien Roy <julien@jroy.ca>2024-11-18 07:40:21 -0500
commitab65972a1848934c5782dd9ea554261a13aec2f7 (patch)
tree495e06a49caf15a102f30f339db0efa7cb8e03a9 /net-im
parentgames-util/pegasus: add missing dependency (diff)
downloadguru-ab65972a1848934c5782dd9ea554261a13aec2f7.tar.gz
guru-ab65972a1848934c5782dd9ea554261a13aec2f7.tar.bz2
guru-ab65972a1848934c5782dd9ea554261a13aec2f7.zip
net-im/mautrix-meta: add 0.4.2
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mautrix-meta/Manifest2
-rw-r--r--net-im/mautrix-meta/mautrix-meta-0.4.2.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/net-im/mautrix-meta/Manifest b/net-im/mautrix-meta/Manifest
index 8a0c5403a..fe0e3ca44 100644
--- a/net-im/mautrix-meta/Manifest
+++ b/net-im/mautrix-meta/Manifest
@@ -2,3 +2,5 @@ DIST mautrix-meta-0.3.1-deps.tar.xz 28436296 BLAKE2B 044812d4dfc89fd7d13e38595de
DIST mautrix-meta-0.3.1.gh.tar.gz 203444 BLAKE2B 294171599408b3f5f40a244d952b7f06678f52c015bb94ce2d4dad0568642fac399467bd86b81036c200b47a74a389614bd41b74e560d92e4de2b77ca58acd5a SHA512 e0141b9adc9361236d24c94a66fdbbfcd10789f7a8f7d7a582f709c2e716eb72b7d4564c5dc58e2a5c82b37709ad2eb3a45e782aca8d74a430d2a15c0ee6db32
DIST mautrix-meta-0.4.1-deps.tar.xz 84314124 BLAKE2B c76b56d663e8c0a54bdc08251dbb5d6ff03eefb7e38fa3f299baff8729bfa5c57bfa0e59f9eb7c3b47727e7940d99721ffec6a7689a9eb65f2405e32fb488c30 SHA512 77f36de178421de676d12536c0a00a19628b44333b1d01758731a0c1f2a79373aa6a32879d7bbcb42a38f85bc2bbcdd32956abadfcd561a41b0fe205100cfb15
DIST mautrix-meta-0.4.1.gh.tar.gz 176127 BLAKE2B ba6a593922608d056be5726c2fcdbfbb08f43f2aeec8f034d4d5dd1c0b8cbda3a86bcba64ca0f01fd8da40febd9db4f70fe6fedeb165a1ef8441ca00125e7a2c SHA512 bb44887072da9f0768e883e1500f98d1726387d295d0cb02f960321ff0c9c1ca1274ead114414b9991d172acf3dd88be93fccdb46be17b89809a529fe1f35b04
+DIST mautrix-meta-0.4.2-deps.tar.xz 84320060 BLAKE2B cdef9d1cadd349b9d3460bd64613eeb41856b4cc4b39385220dc8309e728bed3af874f7a56056f633a0ef7a3bd486da16613fb34fb3c3370ddc82151a60cb796 SHA512 9274e4cf43fe78b8407a7ded8c1ec78f99723264fc49d202018519e17ed64244118a323b9d60dbbdd7042a7b3c5158c7200fba9543c982a3eea6648bf24780d8
+DIST mautrix-meta-0.4.2.gh.tar.gz 176291 BLAKE2B 179b7b7e5fb03b79890b96ad90ec809a80526f043b5ecb40ef1758c44c4aee3401ad5d64d9ec3e975269d5d60496e344067313362fe9740eaa9a5e5facf2a0d8 SHA512 6bc501ac7b5d62e427d1976fba5b3b8a262efdda0fc3859bb0fdb292d2e4ca926989c412b14359391ac9ce2fa1725b90c3a70aa57790eba81038c64386679b16
diff --git a/net-im/mautrix-meta/mautrix-meta-0.4.2.ebuild b/net-im/mautrix-meta/mautrix-meta-0.4.2.ebuild
new file mode 100644
index 000000000..8b30d50b0
--- /dev/null
+++ b/net-im/mautrix-meta/mautrix-meta-0.4.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="A Matrix-Facebook puppeting bridge"
+HOMEPAGE="https://github.com/mautrix/meta"
+SRC_URI="https://github.com/mautrix/meta/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://jroy.ca/dist/${P}-deps.tar.xz
+"
+S="${WORKDIR}/meta-${PV}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-user/${PN}
+ dev-libs/olm
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ego build "${S}"/cmd/"${PN}"
+}
+
+src_install() {
+ dobin mautrix-meta
+
+ keepdir /var/log/mautrix/meta
+ fowners -R root:mautrix /var/log/mautrix
+ fperms -R 770 /var/log/mautrix
+ sed -i -e "s/\.\/logs/\/var\/log\/${PN/-/\\\/}/" "${S}/pkg/connector/example-config.yaml" || die
+
+ insinto "/etc/mautrix"
+ newins "${S}/pkg/connector/example-config.yaml" "${PN/-/_}.yaml"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners -R root:mautrix /etc/mautrix
+ fperms -R 770 /etc/mautrix
+}
+
+pkg_postinst() {
+ einfo
+ elog ""
+ elog "Before you can use ${PN}, you must configure it correctly"
+ elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
+ elog "When done, run the following command: emerge --config ${CATEGORY}/${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
+ einfo
+}
+
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/${PN} -c /etc/mautrix/${PN/-/_}.yaml -g -r /var/lib/${PN/-/\/}/registration.yaml"
+}