aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-16 13:07:55 -0500
committerJulien Roy <julien@jroy.ca>2024-11-16 15:19:55 -0500
commit4e45db3e26b164e8cbaa15dec4d89de7081a5c65 (patch)
tree941f5443868bda348771293fac063e9ccc04f696 /net-im
parentnet-im/mautrix-discord: drop 0.6.4 (diff)
downloadguru-4e45db3e26b164e8cbaa15dec4d89de7081a5c65.tar.gz
guru-4e45db3e26b164e8cbaa15dec4d89de7081a5c65.tar.bz2
guru-4e45db3e26b164e8cbaa15dec4d89de7081a5c65.zip
net-im/mautrix-meta: add 0.4.1
Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/mautrix-meta/Manifest2
-rw-r--r--net-im/mautrix-meta/mautrix-meta-0.4.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/net-im/mautrix-meta/Manifest b/net-im/mautrix-meta/Manifest
index 2f8505fa5..10028eb54 100644
--- a/net-im/mautrix-meta/Manifest
+++ b/net-im/mautrix-meta/Manifest
@@ -2,3 +2,5 @@ DIST mautrix-meta-0.3.0-deps.tar.xz 32145360 BLAKE2B 0c3c5a987d602067b9431637589
DIST mautrix-meta-0.3.0.gh.tar.gz 202451 BLAKE2B cf3a7cd2bd27d8a497c42fd960993d1df7714500abc67b9e30d2853e71070262238272ddbec513f056560a57e3e6028183b90a862139bbb6407028c482c2569b SHA512 099c105ad8834f585215d0d9e3db16c1fe6d6064fe480b944e895527e44c069623f7667db8e84f90004df72dd49bdd1e1359b46e7987814e7c41a0b344ec3a67
DIST mautrix-meta-0.3.1-deps.tar.xz 28436296 BLAKE2B 044812d4dfc89fd7d13e38595de1322b14dcbca0ae907c4a6a463047f1ed22e83fa0b825857c3eb134b22f49e7c308749bbf60bbf9725a64ae8b1952b08f7482 SHA512 2f753f1e02a9d6225f7370b3d30c06a91127a2e4d4c4e12032a27e9f0136d7590a52a281369d42b1d7b76f6a5b5c2cffbfbe1ea2a96e1c1eb6f145dcbb483fdb
DIST mautrix-meta-0.3.1.gh.tar.gz 203444 BLAKE2B 294171599408b3f5f40a244d952b7f06678f52c015bb94ce2d4dad0568642fac399467bd86b81036c200b47a74a389614bd41b74e560d92e4de2b77ca58acd5a SHA512 e0141b9adc9361236d24c94a66fdbbfcd10789f7a8f7d7a582f709c2e716eb72b7d4564c5dc58e2a5c82b37709ad2eb3a45e782aca8d74a430d2a15c0ee6db32
+DIST mautrix-meta-0.4.1-deps.tar.xz 84314124 BLAKE2B c76b56d663e8c0a54bdc08251dbb5d6ff03eefb7e38fa3f299baff8729bfa5c57bfa0e59f9eb7c3b47727e7940d99721ffec6a7689a9eb65f2405e32fb488c30 SHA512 77f36de178421de676d12536c0a00a19628b44333b1d01758731a0c1f2a79373aa6a32879d7bbcb42a38f85bc2bbcdd32956abadfcd561a41b0fe205100cfb15
+DIST mautrix-meta-0.4.1.gh.tar.gz 176127 BLAKE2B ba6a593922608d056be5726c2fcdbfbb08f43f2aeec8f034d4d5dd1c0b8cbda3a86bcba64ca0f01fd8da40febd9db4f70fe6fedeb165a1ef8441ca00125e7a2c SHA512 bb44887072da9f0768e883e1500f98d1726387d295d0cb02f960321ff0c9c1ca1274ead114414b9991d172acf3dd88be93fccdb46be17b89809a529fe1f35b04
diff --git a/net-im/mautrix-meta/mautrix-meta-0.4.1.ebuild b/net-im/mautrix-meta/mautrix-meta-0.4.1.ebuild
new file mode 100644
index 000000000..8b30d50b0
--- /dev/null
+++ b/net-im/mautrix-meta/mautrix-meta-0.4.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="A Matrix-Facebook puppeting bridge"
+HOMEPAGE="https://github.com/mautrix/meta"
+SRC_URI="https://github.com/mautrix/meta/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://jroy.ca/dist/${P}-deps.tar.xz
+"
+S="${WORKDIR}/meta-${PV}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-user/${PN}
+ dev-libs/olm
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ego build "${S}"/cmd/"${PN}"
+}
+
+src_install() {
+ dobin mautrix-meta
+
+ keepdir /var/log/mautrix/meta
+ fowners -R root:mautrix /var/log/mautrix
+ fperms -R 770 /var/log/mautrix
+ sed -i -e "s/\.\/logs/\/var\/log\/${PN/-/\\\/}/" "${S}/pkg/connector/example-config.yaml" || die
+
+ insinto "/etc/mautrix"
+ newins "${S}/pkg/connector/example-config.yaml" "${PN/-/_}.yaml"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners -R root:mautrix /etc/mautrix
+ fperms -R 770 /etc/mautrix
+}
+
+pkg_postinst() {
+ einfo
+ elog ""
+ elog "Before you can use ${PN}, you must configure it correctly"
+ elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
+ elog "When done, run the following command: emerge --config ${CATEGORY}/${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
+ einfo
+}
+
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/${PN} -c /etc/mautrix/${PN/-/_}.yaml -g -r /var/lib/${PN/-/\/}/registration.yaml"
+}