aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <marco@scardovi.com>2021-06-27 19:23:03 +0200
committerMarco Scardovi <marco@scardovi.com>2021-06-27 19:26:35 +0200
commite14b57d4679cd38fde03ff8cb5397208a5d20056 (patch)
tree39d287ef206d0e7728e5f2716276f463e0d47f74 /net-dialup
parentdev-python/trio-asyncio: move to ::gentoo (diff)
downloadguru-e14b57d4679cd38fde03ff8cb5397208a5d20056.tar.gz
guru-e14b57d4679cd38fde03ff8cb5397208a5d20056.tar.bz2
guru-e14b57d4679cd38fde03ff8cb5397208a5d20056.zip
net-dialup/atinout: patched Makefile
The original one does not respect CFLAGS/LDFLAGS so with the help of Sam we've patched him to make it respecting *FLAGS Closes: https://bugs.gentoo.org/798909 Closes: https://bugs.gentoo.org/798903 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/atinout/atinout-0.9.1-r1.ebuild (renamed from net-dialup/atinout/atinout-0.9.1.ebuild)4
-rw-r--r--net-dialup/atinout/files/0003-patch-makefile.patch40
2 files changed, 43 insertions, 1 deletions
diff --git a/net-dialup/atinout/atinout-0.9.1.ebuild b/net-dialup/atinout/atinout-0.9.1-r1.ebuild
index 77408bdff..2ef99bfee 100644
--- a/net-dialup/atinout/atinout-0.9.1.ebuild
+++ b/net-dialup/atinout/atinout-0.9.1-r1.ebuild
@@ -16,8 +16,10 @@ KEYWORDS="~amd64 ~arm64"
PATCHES=(
"${FILESDIR}"/0001-make-gcc-happy-by-adding-fallthrough-comment.patch
"${FILESDIR}"/0002-do-not-rely-on-CR-in-modem-output.patch
+ "${FILESDIR}"/0003-patch-makefile.patch
)
src_compile() {
- CC="$(tc-getCC)" emake LDFLAGS="${LDFLAGS}"
+ tc-export CC
+ emake
}
diff --git a/net-dialup/atinout/files/0003-patch-makefile.patch b/net-dialup/atinout/files/0003-patch-makefile.patch
new file mode 100644
index 000000000..871a61efe
--- /dev/null
+++ b/net-dialup/atinout/files/0003-patch-makefile.patch
@@ -0,0 +1,40 @@
+From 404fb66abd5db4ef4b824ec67c56887773c99962 Mon Sep 17 00:00:00 2001
+From: Marco Scardovi <marco@scardovi.com>
+Date: Sun, 27 Jun 2021 18:21:15 +0200
+Subject: [PATCH] patch makefile
+
+Signed-off-by: Marco Scardovi <marco@scardovi.com>
+---
+ Makefile | 12 +++++-------
+ 1 file changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 1daa431..bb27d0b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,17 +1,15 @@
+ VERSION = 0.9.1
+
+-PREFIX = /usr
++PREFIX ?= /usr
+
+-CC = gcc
+-CFLAGS = -W -Wall -Wextra -Werror \
+- -DVERSION=\"$(VERSION)\" \
+- -g
+-LDFLAGS =
++CC ?= gcc
++CFLAGS ?= -W -Wall -Wextra -Werror -g
++LDFLAGS ?=
+
+ all: atinout
+
+ atinout: atinout.c
+- $(CC) -o $@ $(CFLAGS) $(LDFLAGS) $^
++ $(CC) -o $@ $(CFLAGS) $(CPPFLAGS) -DVERSION=\"$(VERSION)\" $(LDFLAGS) $^
+
+ clean:
+ rm -f atinout
+--
+2.32.0
+