aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Smaniotto <smaniotto.nicola@gmail.com>2022-05-30 11:40:54 +0200
committerNicola Smaniotto <smaniotto.nicola@gmail.com>2022-05-30 11:45:56 +0200
commit08ce51bf3fcf3e005e06180b42b91742735a228b (patch)
treebedbb63393284a61a3b53da6a5840b905aa42fbb /mpv-plugin/autoload
parentdev-python/clufter: add python-3.10 (diff)
downloadguru-08ce51bf3fcf3e005e06180b42b91742735a228b.tar.gz
guru-08ce51bf3fcf3e005e06180b42b91742735a228b.tar.bz2
guru-08ce51bf3fcf3e005e06180b42b91742735a228b.zip
mpv-plugin/autoload: add 0.34.1
Signed-off-by: Nicola Smaniotto <smaniotto.nicola@gmail.com>
Diffstat (limited to 'mpv-plugin/autoload')
-rw-r--r--mpv-plugin/autoload/Manifest1
-rw-r--r--mpv-plugin/autoload/autoload-0.34.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/mpv-plugin/autoload/Manifest b/mpv-plugin/autoload/Manifest
index ec4b015b3..94da30585 100644
--- a/mpv-plugin/autoload/Manifest
+++ b/mpv-plugin/autoload/Manifest
@@ -1 +1,2 @@
DIST mpv-0.33.1.tar.gz 3259882 BLAKE2B 97ab101c2013ffb219d36a788020fb9fc4382d09971ac0beee42701a54667a6c766521be7b052193de4505b2117c2d47b3682ebafab46632fc40b637e0d19c04 SHA512 99d6c40d18c5cf83814b44ec6d8eade229800c5b51a734c9bbe831c3aeb95f8931124c94f6ae2360ffff62053c163bc3c55b254df021e005b350ebc3df7e952b
+DIST mpv-0.34.1.tar.gz 3288356 BLAKE2B c0e5dc3cd23307449a526bd2cf0df5d870322aa1914a139784fd50d77274d42648a769ee4da3ba74e34a7a080700a5740dae13ed0827df1b3cfef36846f983ab SHA512 77ea349d6999f8cce9b5cce4cebd3506a224fc18ab08d22dd16bd34c34d012bb170879b268ddd62db40d116b4cc0b2d9d651b8097f387ed9115c426834cac77e
diff --git a/mpv-plugin/autoload/autoload-0.34.1.ebuild b/mpv-plugin/autoload/autoload-0.34.1.ebuild
new file mode 100644
index 000000000..f82929a01
--- /dev/null
+++ b/mpv-plugin/autoload/autoload-0.34.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_MPV="rdepend"
+MPV_REQ_USE="lua"
+inherit mpv-plugin
+
+DESCRIPTION="Loads playlist entries before and after the the currently played file"
+HOMEPAGE="https://github.com/mpv-player/mpv/tree/master/TOOLS/lua"
+
+# use the already available mpv tarball
+SRC_URI="https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> mpv-${PV}.tar.gz"
+
+# since this comes from mpv, use its licenses
+LICENSE="LGPL-2.1+ GPL-2+ BSD ISC"
+KEYWORDS="~amd64"
+
+# lock mpv version
+RDEPEND="~media-video/mpv-${PV}"
+
+S="${WORKDIR}/mpv-${PV}/TOOLS/lua"
+
+MPV_PLUGIN_FILES=( ${PN}.lua )