aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Fox <flewkey@2a03.party>2021-04-14 22:30:36 +0000
committerRyan Fox <flewkey@2a03.party>2021-04-14 22:32:01 +0000
commitc3e32feb1e04ae1cdd628376e82f9ae32fc5fcb0 (patch)
treed4c52604f6be7996cd31d4a94d6329301eb1fb1c /media-libs
parentdev-libs/tllist: New package (diff)
downloadguru-c3e32feb1e04ae1cdd628376e82f9ae32fc5fcb0.tar.gz
guru-c3e32feb1e04ae1cdd628376e82f9ae32fc5fcb0.tar.bz2
guru-c3e32feb1e04ae1cdd628376e82f9ae32fc5fcb0.zip
media-libs/fcft: New package
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Ryan Fox <flewkey@2a03.party>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fcft/Manifest1
-rw-r--r--media-libs/fcft/fcft-2.3.3.ebuild43
-rw-r--r--media-libs/fcft/fcft-9999.ebuild43
-rw-r--r--media-libs/fcft/metadata.xml11
4 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/fcft/Manifest b/media-libs/fcft/Manifest
new file mode 100644
index 000000000..6999a947f
--- /dev/null
+++ b/media-libs/fcft/Manifest
@@ -0,0 +1 @@
+DIST fcft-2.3.3.tar.gz 313168 BLAKE2B b3dbc3af511e8a8007a17400fe6880a08a62ca0cb69795438ab7c6a86f856b25a3bd26cdef8031f1c8d66f4527d191a72ce87852f001e05b8f37285dea4befb5 SHA512 91f3c1292889c2fd1cdce439e0168a37a932d3a05ea78fff93ce69ea7b1adc33424e67a0b2c36931d26128e1169e6f784f16445475c94690dedf608f92278009
diff --git a/media-libs/fcft/fcft-2.3.3.ebuild b/media-libs/fcft/fcft-2.3.3.ebuild
new file mode 100644
index 000000000..6315f733f
--- /dev/null
+++ b/media-libs/fcft/fcft-2.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/fcft.git"
+fi
+
+DESCRIPTION="A simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+LICENSE="MIT"
+SLOT="0"
+IUSE="+text-shaping"
+
+DEPEND="
+ dev-libs/tllist
+ media-libs/fontconfig
+ media-libs/freetype
+ text-shaping? ( media-libs/harfbuzz )
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature text-shaping)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}"
+}
diff --git a/media-libs/fcft/fcft-9999.ebuild b/media-libs/fcft/fcft-9999.ebuild
new file mode 100644
index 000000000..6315f733f
--- /dev/null
+++ b/media-libs/fcft/fcft-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://codeberg.org/dnkl/fcft.git"
+fi
+
+DESCRIPTION="A simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+LICENSE="MIT"
+SLOT="0"
+IUSE="+text-shaping"
+
+DEPEND="
+ dev-libs/tllist
+ media-libs/fontconfig
+ media-libs/freetype
+ text-shaping? ( media-libs/harfbuzz )
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature text-shaping)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}"
+}
diff --git a/media-libs/fcft/metadata.xml b/media-libs/fcft/metadata.xml
new file mode 100644
index 000000000..5a2954ab2
--- /dev/null
+++ b/media-libs/fcft/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>flewkey@2a03.party</email>
+ <name>Ryan Fox</name>
+ </maintainer>
+ <use>
+ <flag name="text-shaping">Support text shaping using HarfBuzz</flag>
+ </use>
+</pkgmetadata>