aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDex Conner <cantcuckthis@danwin1210.de>2022-04-10 12:04:08 +0300
committerDex Conner <cantcuckthis@danwin1210.de>2022-04-10 12:04:08 +0300
commit2ef527588352d9e95b72da03cfc5cd4ec5922fd0 (patch)
tree24a1084eafd03436f9369442044d2959bc811ea8 /gui-apps/somebar
parentmedia-gfx/superslicer: add 2.3.57.12 ebuild (diff)
downloadguru-2ef527588352d9e95b72da03cfc5cd4ec5922fd0.tar.gz
guru-2ef527588352d9e95b72da03cfc5cd4ec5922fd0.tar.bz2
guru-2ef527588352d9e95b72da03cfc5cd4ec5922fd0.zip
gui-apps/somebar: initial import
Signed-off-by: Dex Conner <cantcuckthis@danwin1210.de>
Diffstat (limited to 'gui-apps/somebar')
-rw-r--r--gui-apps/somebar/metadata.xml8
-rw-r--r--gui-apps/somebar/somebar-9999.ebuild38
2 files changed, 46 insertions, 0 deletions
diff --git a/gui-apps/somebar/metadata.xml b/gui-apps/somebar/metadata.xml
new file mode 100644
index 000000000..2ad19f02c
--- /dev/null
+++ b/gui-apps/somebar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cantcuckthis@danwin1210.de</email>
+ <name>Dex Conner</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-apps/somebar/somebar-9999.ebuild b/gui-apps/somebar/somebar-9999.ebuild
new file mode 100644
index 000000000..1ec94a368
--- /dev/null
+++ b/gui-apps/somebar/somebar-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig git-r3 meson
+
+DESCRIPTION="dwm-like bar for dwl"
+HOMEPAGE="https://git.sr.ht/~raphi/somebar"
+EGIT_REPO_URI="https://git.sr.ht/~raphi/somebar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ dev-util/meson
+ dev-util/ninja
+"
+
+src_prepare() {
+ default
+ use savedconfig && restore_config src/config.hpp
+ [ -f src/config.hpp ] || cp src/config.def.hpp src/config.hpp
+}
+
+src_install() {
+ meson_install
+ save_config src/config.hpp
+}