aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-12 15:20:45 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-12 15:21:05 +0200
commit7f7effd8d910828eb854a3865e8ba328f464af63 (patch)
tree47c5bd8afd26b2f35b280daa98f26fbbbe22a910 /gui-apps/corepaint
parentmedia-gfx/akira: Add new package. (diff)
downloadguru-7f7effd8d910828eb854a3865e8ba328f464af63.tar.gz
guru-7f7effd8d910828eb854a3865e8ba328f464af63.tar.bz2
guru-7f7effd8d910828eb854a3865e8ba328f464af63.zip
gui-*: bump cubocore to 4.2.0
Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'gui-apps/corepaint')
-rw-r--r--gui-apps/corepaint/Manifest1
-rw-r--r--gui-apps/corepaint/corepaint-4.2.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/gui-apps/corepaint/Manifest b/gui-apps/corepaint/Manifest
index 62b8c0208..d720995fd 100644
--- a/gui-apps/corepaint/Manifest
+++ b/gui-apps/corepaint/Manifest
@@ -1,3 +1,4 @@
DIST corepaint-4.0.0.tar.gz 95037 BLAKE2B ac7ba3bcd28057206801211b87a7d420f94a9a46147008644d9b7d59169f48e3fc2a78f3ea2db5c034fa97b922b25b4d94025a2001293acc62aab74ab8d105d0 SHA512 dbb0a37100d9bd01b3512080e98162c6a25d3ab5ff19be3fefedf35c3398bdb160ad1ba2c9cb5d6950582c6bfc99d75c3768edf45fa6cfe1b898fb11a7ac4a9a
DIST corepaint-4.1.0.tar.gz 96506 BLAKE2B a5ec05d35e1d6ce086bb7ef55a0efbfe34273510b446492835e532e2420c52998495bba63e7cc4ce1080e144b1aa8bc5f10c06e58e1d6c0718b41c8c084c489d SHA512 c49d2388436e13717edaa957d7a81de2cf348324317baab27fbe1f9ef0a7086095c6996ee09300d350945af4dd1abe2f736dfcf49886443e0474245ff327227a
+DIST corepaint-4.2.0.tar.gz 109114 BLAKE2B a79bbfa6e6aebc005338347193b5c14d41c1d5f40cee41f2493934b63034c9bb47d3c6021fe93a0d6e9ac0e776af65a60d930bd451d70c7acec3a46545363e39 SHA512 23ccfc465bfe00cb14ddc4dc607d23606456ee1856c20529194922786d5e6d956d4854271d7a91605d5849d7581c8e508b25688759465d77d43fa7b0fd2db027
DIST corepaint-4.2.0_alpha.tar.gz 108589 BLAKE2B 148739b145df83939733ae1797b83c60c6b8a161b13cfdb44ce1c478bb3671639487a025cf1cf7d3fe1e4f11ccdf93b75bbf8b3393a6bd85e2ea007efbec7f1c SHA512 3dcf40200b1677452f4eef7028e8036a883cb5072bbda2ddd50084607daf779124ab2709a974efb167e6b9b41c12085d1865ad56bc46ea70f554f293abe636ee
diff --git a/gui-apps/corepaint/corepaint-4.2.0.ebuild b/gui-apps/corepaint/corepaint-4.2.0.ebuild
new file mode 100644
index 000000000..f5a7ba9c9
--- /dev/null
+++ b/gui-apps/corepaint/corepaint-4.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="${PV/_/-}"
+
+inherit xdg cmake
+
+DESCRIPTION="A paint app for C Suite"
+HOMEPAGE="https://gitlab.com/cubocore/coreapps/corepaint"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/cubocore/coreapps/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/cubocore/coreapps/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${MY_PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ gui-libs/libcprime
+"
+RDEPEND="
+ ${DEPEND}
+"