aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2022-05-11 21:06:04 +0200
committerAdel KARA SLIMANE <adel.ks@zegrapher.com>2022-05-11 21:06:04 +0200
commitf7289cf91664bed749fdac2ff6ac6ed7615f8911 (patch)
treebec3d5761fa5ba94f7c3cbddd3e5e9368cea5d8c /games-util/mangohud
parentgames-util/mangohud: inherit python-any-r1 and add libdrm as dep (diff)
downloadguru-f7289cf91664bed749fdac2ff6ac6ed7615f8911.tar.gz
guru-f7289cf91664bed749fdac2ff6ac6ed7615f8911.tar.bz2
guru-f7289cf91664bed749fdac2ff6ac6ed7615f8911.zip
games-util/mangohud: properly uses python-any-r1 eclass
Using https://projects.gentoo.org/python/guide/any.html Thanks @ionenwks @arthurzam Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com>
Diffstat (limited to 'games-util/mangohud')
-rw-r--r--games-util/mangohud/mangohud-0.6.6.1-r3.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/games-util/mangohud/mangohud-0.6.6.1-r3.ebuild b/games-util/mangohud/mangohud-0.6.6.1-r3.ebuild
index ca29f2673..99f91b86a 100644
--- a/games-util/mangohud/mangohud-0.6.6.1-r3.ebuild
+++ b/games-util/mangohud/mangohud-0.6.6.1-r3.ebuild
@@ -5,10 +5,10 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit python-any-r1 distutils-r1 meson
+inherit python-any-r1 meson
MY_PV=$(ver_cut 1-3)
-[ -n "$(ver_cut 4)" ] && MY_PV_REV="-$(ver_cut 4)"
+[[ -n "$(ver_cut 4)" ]] && MY_PV_REV="-$(ver_cut 4)"
IMGUI_VER="1.81"
IMGUI_MESON_WRAP_VER="1"
@@ -34,9 +34,13 @@ REQUIRED_USE="
BDEPEND="
app-arch/unzip
- dev-python/mako[${PYTHON_USEDEP}]
+ $(python_gen_any_dep 'dev-python/mako[${PYTHON_USEDEP}]')
"
+python_check_deps() {
+ python_has_version "dev-python/mako[${PYTHON_USEDEP}]"
+}
+
DEPEND="
dev-libs/spdlog
dev-util/glslang