aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2023-05-25 00:11:03 +0200
committerLucio Sauer <watermanpaint@posteo.net>2023-05-25 00:37:52 +0200
commite36deb40911e7c1ecca7c815be43296e663a788b (patch)
tree13740cb1993ac8f2e7f4d8bd4afb5ca53e2fe73c /dev-python
parentapp-misc/anki-bin: drop 2.1.63 (diff)
downloadguru-e36deb40911e7c1ecca7c815be43296e663a788b.tar.gz
guru-e36deb40911e7c1ecca7c815be43296e663a788b.tar.bz2
guru-e36deb40911e7c1ecca7c815be43296e663a788b.zip
dev-python/types-requests: add 2.31.0.0
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/types-requests/Manifest1
-rw-r--r--dev-python/types-requests/types-requests-2.31.0.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/types-requests/Manifest b/dev-python/types-requests/Manifest
index cb7930254..12c06aff9 100644
--- a/dev-python/types-requests/Manifest
+++ b/dev-python/types-requests/Manifest
@@ -1 +1,2 @@
DIST types-requests-2.30.0.0.tar.gz 14922 BLAKE2B a682fd934221e6da2deec781d8cd1facf816636d9cc8395d29ae8bf3be958cf1d90420cb54f64f24f8562d6cb613e61100a211e1d627a7abcc82320a4b7bbaa1 SHA512 7ffa1dca0839a581c1ef47846b01f7861b92ec62e90e0fe17ff007de56366a259541653a8df1517d7dc3b46c8fabfbac362b164a21ceb7fb31ae3f6dcc7b605b
+DIST types-requests-2.31.0.0.tar.gz 15131 BLAKE2B f4f8a2c981504742b103fe51867d4cfb2c1cb971b069bf451943780027bfdb986ecaf84aa2e51c04654b541b91efa98009d846c2b5a99b5889900c3e2a8ec617 SHA512 d6e043f873f41474182995251aeecf2975eb8255eee286d53c7772b174bbf013ecef3e6d78c05bb7af69fee1da2d4854ec01bf324dc8f5e78b0ca827526e43e7
diff --git a/dev-python/types-requests/types-requests-2.31.0.0.ebuild b/dev-python/types-requests/types-requests-2.31.0.0.ebuild
new file mode 100644
index 000000000..9cba92dc6
--- /dev/null
+++ b/dev-python/types-requests/types-requests-2.31.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Typing stubs for requests"
+HOMEPAGE="
+ https://pypi.org/project/types-requests/
+ https://github.com/python/typeshed/tree/master/stubs/requests
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/types-urllib3"