aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-13 20:41:01 -0400
committerJulien Roy <julien@jroy.ca>2024-04-13 20:41:01 -0400
commite9884f29bd3c153b694bfff42b1c1d6b3f278456 (patch)
treed7ce4c71988904c4974fa7ea1e45b81d00216e1c /dev-python/yams
parentnet-libs/dpdk: drop 21.11.1-r1, 22.07-r1 (diff)
downloadguru-e9884f29bd3c153b694bfff42b1c1d6b3f278456.tar.gz
guru-e9884f29bd3c153b694bfff42b1c1d6b3f278456.tar.bz2
guru-e9884f29bd3c153b694bfff42b1c1d6b3f278456.zip
dev-python/yams: enable py3.12, use PEP517
Closes: https://bugs.gentoo.org/897604 Closes: https://bugs.gentoo.org/921883 Signed-off-by: Julien Roy <julien@jroy.ca>
Diffstat (limited to 'dev-python/yams')
-rw-r--r--dev-python/yams/Manifest2
-rw-r--r--dev-python/yams/yams-0.7.3-r1.ebuild (renamed from dev-python/yams/yams-0.7.3.ebuild)16
-rw-r--r--dev-python/yams/yams-9999.ebuild14
3 files changed, 10 insertions, 22 deletions
diff --git a/dev-python/yams/Manifest b/dev-python/yams/Manifest
index cd4697dd3..d8979f306 100644
--- a/dev-python/yams/Manifest
+++ b/dev-python/yams/Manifest
@@ -1 +1 @@
-DIST yams-0.7.3.tar.gz 31201 BLAKE2B 0b09157c545c3ffe4b2b792c8bd00ebf66f78b65a45904db397b7295d43f4cdefd18c5ef855b88f5652debf6c43902d8e8415cf6d134c51d225bc6ae6ba084dc SHA512 785aae9ce0e371e50dac4070a06102d6ac440acd179b6840d4283b0298dd0ae36f12b9f695ddbf7ee2bb281e4d6e1cfd600a444c4169d5652662da1f8c52f43d
+DIST yams-0.7.3.gh.tar.gz 31201 BLAKE2B 0b09157c545c3ffe4b2b792c8bd00ebf66f78b65a45904db397b7295d43f4cdefd18c5ef855b88f5652debf6c43902d8e8415cf6d134c51d225bc6ae6ba084dc SHA512 785aae9ce0e371e50dac4070a06102d6ac440acd179b6840d4283b0298dd0ae36f12b9f695ddbf7ee2bb281e4d6e1cfd600a444c4169d5652662da1f8c52f43d
diff --git a/dev-python/yams/yams-0.7.3.ebuild b/dev-python/yams/yams-0.7.3-r1.ebuild
index 4d4d153c7..9e5c63c71 100644
--- a/dev-python/yams/yams-0.7.3.ebuild
+++ b/dev-python/yams/yams-0.7.3-r1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1 systemd
DESCRIPTION="Yet Another MPD Scrobbler (for Last.FM)"
@@ -13,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/Berulacks/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/Berulacks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/Berulacks/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64"
fi
@@ -28,14 +30,6 @@ RDEPEND="
media-sound/mpd
"
-python_prepare_all() {
- # Change application name so the .egg-info directory has the
- # same name as the Python site-package one for consistency
- sed -e "s/YAMScrobbler/yams/" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
python_install_all() {
systemd_douserunit yams.service
diff --git a/dev-python/yams/yams-9999.ebuild b/dev-python/yams/yams-9999.ebuild
index 1824ef057..9e5c63c71 100644
--- a/dev-python/yams/yams-9999.ebuild
+++ b/dev-python/yams/yams-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_10 )
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1 systemd
DESCRIPTION="Yet Another MPD Scrobbler (for Last.FM)"
@@ -13,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/Berulacks/${PN}.git"
inherit git-r3
else
- SRC_URI="https://github.com/Berulacks/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/Berulacks/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64"
fi
@@ -28,14 +30,6 @@ RDEPEND="
media-sound/mpd
"
-python_prepare_all() {
- # Change application name so the .egg-info directory has the
- # same name as the Python site-package one for consistency
- sed -e "s/YAMScrobbler/yams/" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
python_install_all() {
systemd_douserunit yams.service