aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 13:56:04 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-30 14:09:10 +0200
commitcfbb914590a6de68b9fb8c111373ef23bf0b09ea (patch)
tree6286740e2782de6556ee47902c3334da92db1e1b /dev-python/types-requests
parentdev-python/types-urllib3: add 1.26.15 (diff)
downloadguru-cfbb914590a6de68b9fb8c111373ef23bf0b09ea.tar.gz
guru-cfbb914590a6de68b9fb8c111373ef23bf0b09ea.tar.bz2
guru-cfbb914590a6de68b9fb8c111373ef23bf0b09ea.zip
dev-python/types-requests: add 2.27.29
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/types-requests')
-rw-r--r--dev-python/types-requests/Manifest1
-rw-r--r--dev-python/types-requests/types-requests-2.27.29.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/types-requests/Manifest b/dev-python/types-requests/Manifest
index 2799c749d..90d6707a9 100644
--- a/dev-python/types-requests/Manifest
+++ b/dev-python/types-requests/Manifest
@@ -1 +1,2 @@
DIST types-requests-2.27.27.tar.gz 11345 BLAKE2B 41239c8c64af3cae256f28b518f5ef89b1b3743730d382a3de5f0aa0b332358b3cee6e2acc3db0ecd2f52412ea4fbc0f648cbd1d856bf2d524a747c9d57fc8b8 SHA512 68bd04b7c7c0a712dbadb3f92f28547a95ddf3b03c372f4dff0f7ce45bfabe0f3f896cad65694adec13f6bbb20a5104eef98939ba0a5f8141812a5c16eda3347
+DIST types-requests-2.27.29.tar.gz 11366 BLAKE2B 4791fbcc95bbb16de6aa341afdf7b08d5f147628d3f2bc5b43c512e9df509a8fcdf95ac4f9c7f4f924aa5463040157730b33953a15144afd2d9b4adb7c16e48a SHA512 136acd5d1ae2334ecbe19c2dcac59d2c8d7c567bb5c4a0d15c279bcf61be1abebfb934743d5ad3c2792eaca6c6cc76756e9efa550448a831727de0846548f0a9
diff --git a/dev-python/types-requests/types-requests-2.27.29.ebuild b/dev-python/types-requests/types-requests-2.27.29.ebuild
new file mode 100644
index 000000000..0dde177cf
--- /dev/null
+++ b/dev-python/types-requests/types-requests-2.27.29.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Typing stubs for requests"
+HOMEPAGE="
+ https://pypi.org/project/types-requests/
+ https://github.com/python/typeshed/tree/master/stubs/requests
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+
+RDEPEND="<dev-python/types-urllib3-1.27"
+DEPEND="${RDEPEND}"