aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-29 14:38:29 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-04-29 14:38:44 +0500
commit7e65d172efe23c93b119462a07b89e26928e7fff (patch)
treee90c432d4ca97498238ec62f95d25dde75670980 /dev-python/sphinx-sitemap
parentapp-misc/agg: new package, add 1.4.3 (diff)
downloadguru-7e65d172efe23c93b119462a07b89e26928e7fff.tar.gz
guru-7e65d172efe23c93b119462a07b89e26928e7fff.tar.bz2
guru-7e65d172efe23c93b119462a07b89e26928e7fff.zip
dev-python/sphinx-sitemap: add 2.6.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/sphinx-sitemap')
-rw-r--r--dev-python/sphinx-sitemap/Manifest1
-rw-r--r--dev-python/sphinx-sitemap/sphinx-sitemap-2.6.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinx-sitemap/Manifest b/dev-python/sphinx-sitemap/Manifest
index aecf1a887..0340c8f83 100644
--- a/dev-python/sphinx-sitemap/Manifest
+++ b/dev-python/sphinx-sitemap/Manifest
@@ -1 +1,2 @@
DIST sphinx-sitemap-2.5.1.gh.tar.gz 26496 BLAKE2B 390050befcd3295d7d9e63495bc5095eb18c9d510db834fb221a796d28d6b8944aa8b7935c3f3018eb9ae59f6b8aba47703ae2af2cc8b9ed1ebb144fe093736a SHA512 9a470d0717f69f01178c2bc0ef8fc825824a534ceb37f1d0aec8feb36aea8c5d3fe92a3d60e34d2e4f30bc0318f497abfdb6221de42418d935da7563caeaca48
+DIST sphinx-sitemap-2.6.0.gh.tar.gz 27157 BLAKE2B fe9b8b3df5d5ca84a13e7c99adca9e1eda3b2c89135293ebb07f2575c98fdec517f45eaec8429404b7d9b08d43b0d24cd1113a48ec3e12396dce6b3e0979287b SHA512 cfe5f575c77790cf7c5b6a5765d03e39059bce62b3ec0d908a9d2ec2071c3f1d104ee0ab8b1ca77343f327b8cd7c31d4cb5588c92d5ade9ba6f6e44b0fc35c4c
diff --git a/dev-python/sphinx-sitemap/sphinx-sitemap-2.6.0.ebuild b/dev-python/sphinx-sitemap/sphinx-sitemap-2.6.0.ebuild
new file mode 100644
index 000000000..8ba84a896
--- /dev/null
+++ b/dev-python/sphinx-sitemap/sphinx-sitemap-2.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Sitemap generator for Sphinx"
+HOMEPAGE="
+ https://pypi.org/project/sphinx-sitemap/
+ https://github.com/jdillard/sphinx-sitemap
+"
+SRC_URI="https://github.com/jdillard/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+#distutils_enable_sphinx docs/source \
+ #dev-python/furo \
+ #dev-python/sphinxemoji \
+ #dev-python/sphinxext-opengraph \
+ #dev-python/sphinx-contributors