aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorShaoyu Tseng <shaoyu0209@tuta.io>2021-08-08 14:44:55 +0800
committerShaoyu Tseng <shaoyu0209@tuta.io>2021-08-08 14:44:55 +0800
commitd443590e45117f86eee38c56b7faa45bbc939193 (patch)
tree2ec4a17402d8967787dc900cb95ad6fd0008bb1a /dev-python/pystardict
parentdev-python/bidict: new package (diff)
downloadguru-d443590e45117f86eee38c56b7faa45bbc939193.tar.gz
guru-d443590e45117f86eee38c56b7faa45bbc939193.tar.bz2
guru-d443590e45117f86eee38c56b7faa45bbc939193.zip
dev-python/pystardict: new package
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Shaoyu Tseng <shaoyu0209@tuta.io>
Diffstat (limited to 'dev-python/pystardict')
-rw-r--r--dev-python/pystardict/Manifest1
-rw-r--r--dev-python/pystardict/metadata.xml12
-rw-r--r--dev-python/pystardict/pystardict-0.8.ebuild23
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pystardict/Manifest b/dev-python/pystardict/Manifest
new file mode 100644
index 000000000..0e327a8b6
--- /dev/null
+++ b/dev-python/pystardict/Manifest
@@ -0,0 +1 @@
+DIST pystardict-0.8.tar.gz 795302 BLAKE2B eed78612e616a56920ab40035dd14682d8420d34919df8f00deabdf36b287723cd12815cda9bb3c5eb9d6d123edd961dbd5da7301a4f5c5ac56b0b49665a5050 SHA512 a5cb64993e4d870c3fb30e78462ac52bba994088b51d74e2eb7a0c41436bd1bb6733c6a11f30404eae446669209a7dc8f8d74efb28f5cce3997c26fcad833db7
diff --git a/dev-python/pystardict/metadata.xml b/dev-python/pystardict/metadata.xml
new file mode 100644
index 000000000..48d8dfb88
--- /dev/null
+++ b/dev-python/pystardict/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<upstream>
+<remote-id type="pypi">PyStarDict</remote-id>
+<remote-id type="github">lig/pystardict</remote-id>
+</upstream>
+<maintainer type="person">
+<email>shaoyu0209@tuta.io</email>
+<name>shaoyu</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/pystardict/pystardict-0.8.ebuild b/dev-python/pystardict/pystardict-0.8.ebuild
new file mode 100644
index 000000000..176b4bbf3
--- /dev/null
+++ b/dev-python/pystardict/pystardict-0.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+UP="PyStarDict"
+S="${WORKDIR}/${UP}-${PV}"
+DESCRIPTION="Library for manipulating StarDict dictionaries from within Python"
+HOMEPAGE="https://github.com/lig/pystardict https://pypi.org/project/PyStarDict/"
+SRC_URI="mirror://pypi/${UP:0:1}/${UP}/${UP}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm64 ~arm"
+
+DEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""