aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2023-02-06 14:30:21 +0100
committerHenri Gasc <gasc@eurecom.fr>2023-02-06 19:40:26 +0100
commit20fa7fcdad76c92f541b3d9e965450185f4dca87 (patch)
tree403d19da49302537bdb42e382f78e0ca439390a2 /dev-python/moderngl
parentdev-python/glcontext: Allow test (diff)
downloadguru-20fa7fcdad76c92f541b3d9e965450185f4dca87.tar.gz
guru-20fa7fcdad76c92f541b3d9e965450185f4dca87.tar.bz2
guru-20fa7fcdad76c92f541b3d9e965450185f4dca87.zip
dev-python/moderngl: Enable tests
Closes: https://bugs.gentoo.org/893394 Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'dev-python/moderngl')
-rw-r--r--dev-python/moderngl/moderngl-5.7.4.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-python/moderngl/moderngl-5.7.4.ebuild b/dev-python/moderngl/moderngl-5.7.4.ebuild
index 86e280104..64bd4a98e 100644
--- a/dev-python/moderngl/moderngl-5.7.4.ebuild
+++ b/dev-python/moderngl/moderngl-5.7.4.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
+inherit distutils-r1 virtualx
DESCRIPTION="Modern OpenGL binding for python"
HOMEPAGE="https://github.com/moderngl/moderngl https://pypi.org/project/moderngl"
@@ -34,14 +34,13 @@ BDEPEND="
"
DEPEND="${BDEPEND}"
-# Tests are deactivated because we cannot open display
-# distutils_enable_tests pytest
-# python_test() {
-# cd "${T}" || die
-# epytest "${S}"/tests
-# }
+distutils_enable_tests pytest
-pkg_postinst() {
- use test && ewarn The tests for this package are deactivated because the test display can not be opened.
- use test && ewarn If you know how to solve this issue, please do so.
+src_test() {
+ virtx distutils-r1_src_test
+}
+python_test() {
+ rm "${S}/tests/test_local.py"
+ cd "${T}" || die
+ epytest "${S}"/tests
}