aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-29 14:08:02 +0200
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-29 14:08:02 +0200
commit753fddeb8ad024ecf4d363ff836e9db1673b38ec (patch)
tree696b668c6be8a2487905539be325710b67eb70d0 /dev-python/manhole
parentdev-python/outcome: add missing dep sphinxcontrib_trio (diff)
downloadguru-753fddeb8ad024ecf4d363ff836e9db1673b38ec.tar.gz
guru-753fddeb8ad024ecf4d363ff836e9db1673b38ec.tar.bz2
guru-753fddeb8ad024ecf4d363ff836e9db1673b38ec.zip
dev-python/manhole: tried and failed to get tests working
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/manhole')
-rw-r--r--dev-python/manhole/manhole-1.6.0.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/manhole/manhole-1.6.0.ebuild b/dev-python/manhole/manhole-1.6.0.ebuild
index 37db2bb6e..24175bac7 100644
--- a/dev-python/manhole/manhole-1.6.0.ebuild
+++ b/dev-python/manhole/manhole-1.6.0.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_6 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -17,8 +19,11 @@ HOMEPAGE="
SRC_URI="https://github.com/ionelmc/${MYPN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
+
KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
RDEPEND=""
DEPEND="
${RDEPEND}
@@ -28,19 +33,12 @@ DEPEND="
dev-python/process-tests[${PYTHON_USEDEP}]
dev-python/pytest-travis-fold[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
- www-servers/uwsgi[${PYTHON_USEDEP}]
+ www-servers/uwsgi[python,python_gevent,${PYTHON_USEDEP}]
)
"
S="${WORKDIR}/${MYPN}-${PV}"
-python_prepare_all() {
- #no coverage
- #sed -i 's|--cov-report term-missing||' setup.cfg || die
- #sed -i 's|nocover: false|nocover: true|' setup.cfg || die
- distutils-r1_python_prepare_all
-}
-
distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx-py3doc-enhanced-theme \