aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Zuber <a.zuber@gmx.ch>2021-03-17 12:45:19 +0100
committerAndreas Zuber <a.zuber@gmx.ch>2021-03-17 12:46:41 +0100
commit50e96b7c84fd8a5515c98407967a876f9e66059a (patch)
treef7ccee501f65e5d7d2fa3d74a55fcbbdf6fccef6 /dev-python/libusb1
parentmedia-plugins/qt-jpegxl-image-plugin: new package (diff)
downloadguru-50e96b7c84fd8a5515c98407967a876f9e66059a.tar.gz
guru-50e96b7c84fd8a5515c98407967a876f9e66059a.tar.bz2
guru-50e96b7c84fd8a5515c98407967a876f9e66059a.zip
dev-python/libusb1: version bump to 1.9.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andreas Zuber <a.zuber@gmx.ch>
Diffstat (limited to 'dev-python/libusb1')
-rw-r--r--dev-python/libusb1/Manifest1
-rw-r--r--dev-python/libusb1/libusb1-1.9.2.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/libusb1/Manifest b/dev-python/libusb1/Manifest
index 3d73b1d37..0b81396b5 100644
--- a/dev-python/libusb1/Manifest
+++ b/dev-python/libusb1/Manifest
@@ -1 +1,2 @@
DIST libusb1-1.9.1.tar.gz 79646 BLAKE2B c960efe5b14d5440944842f40d2783528dbdd899631aaa5ada0da575687051930f706e58fc0582e6ae68bebb8d26eaa49b6a5982e4b53ba088596740f4165ad8 SHA512 11559b963a958ccfa7ce957b65eb20af70ff2fcfe6b81f7939744d49df295a5f02ed8a80d2b67df61f945bca553f4424c98115c102bbacd4a0609d1e2e7fbf34
+DIST libusb1-1.9.2.tar.gz 80139 BLAKE2B 954fb72165e1bb94c5bad5b116e96272f3d8bd07215463a53a0f15f1c98e568dc2a710b23d46829ec870f2baec6184450d68ca280ac3c12af806cb1dde94e33a SHA512 cae50daa7abf367941bc136295adaac33996db5811d6fa302802b3a97d643c7145f0faa370d130d72bc356999e60003b0420700143739fee7c8ba8ddca264788
diff --git a/dev-python/libusb1/libusb1-1.9.2.ebuild b/dev-python/libusb1/libusb1-1.9.2.ebuild
new file mode 100644
index 000000000..f8ea69f47
--- /dev/null
+++ b/dev-python/libusb1/libusb1-1.9.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-python wrapper for libusb-1.0"
+HOMEPAGE="https://github.com/vpelletier/python-libusb1"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="virtual/libusb"
+DEPEND="dev-python/wheel[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py