aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-01-06 08:06:12 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-01-06 08:08:11 +0500
commit58b36e7983fdf13e4fa710f25651d8026465eb5d (patch)
treeb32d41363173a76097f09a57887c8ae69cb4c413 /dev-python/azure-core
parentdev-python/sphinx-argparse-cli: add 1.11.0, drop 1.8.2 (diff)
downloadguru-58b36e7983fdf13e4fa710f25651d8026465eb5d.tar.gz
guru-58b36e7983fdf13e4fa710f25651d8026465eb5d.tar.bz2
guru-58b36e7983fdf13e4fa710f25651d8026465eb5d.zip
dev-python/azure-core: add 1.26.2
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/azure-core')
-rw-r--r--dev-python/azure-core/Manifest1
-rw-r--r--dev-python/azure-core/azure-core-1.26.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/azure-core/Manifest b/dev-python/azure-core/Manifest
index 5bcbdfcfb..2f7cd29f4 100644
--- a/dev-python/azure-core/Manifest
+++ b/dev-python/azure-core/Manifest
@@ -1 +1,2 @@
DIST azure-core-1.26.1.zip 366521 BLAKE2B 538aa1699bc708744800f98391d4913f3bed561718f9143394d4f6b7cbe18097054e941882f6237e9c8fef2d218c955f3b0a8c2cb23e51121c05cb5437afd4f9 SHA512 dcddf28bdbac913e66640adb7c511c74e4597756c444d2ef43fb82d5348eae391544715cbe95600d8caec9afcfe8ab5d20b9b33c49b8fd026b8f0f7657cae931
+DIST azure-core-1.26.2.zip 368264 BLAKE2B 72c611f506c1773917a15dd354b8d97922d7f5b24e114a4e45a7fb3a65505ae5019aa4b6993c37c3840d6bffce648cb2b065904420cc3034209f58e55d2513f7 SHA512 3084c8f24d01e4a283175839be673061b8de13ffa85ab956f3753bd64cd0efb4eff421e239a41433834a8de9a3af620ddb27f24f1fcb475ec963456c0a86a084
diff --git a/dev-python/azure-core/azure-core-1.26.2.ebuild b/dev-python/azure-core/azure-core-1.26.2.ebuild
new file mode 100644
index 000000000..b2487e710
--- /dev/null
+++ b/dev-python/azure-core/azure-core-1.26.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Microsoft Azure Core Library for Python"
+HOMEPAGE="
+ https://pypi.org/project/azure-core/
+ https://github.com/Azure/azure-sdk-for-python
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="app-arch/unzip"
+# TODO: package azure-sdk-tools
+#BDEPEND="
+# app-arch/unzip
+# test? (
+# dev-python/aiohttp[${PYTHON_USEDEP}]
+# dev-python/azure-sdk-tools[${PYTHON_USEDEP}]
+# dev-python/flask[${PYTHON_USEDEP}]
+# dev-python/msrest[${PYTHON_USEDEP}]
+# dev-python/pytest-trio[${PYTHON_USEDEP}]
+# dev-python/requests[${PYTHON_USEDEP}]
+# )
+#"
+
+DOCS=( {CHANGELOG,CLIENT_LIBRARY_DEVELOPER,README}.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "aio support" dev-python/aiohttp
+}