aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Carvalho <tomas@thetimesweeper.com>2023-12-30 14:59:02 +0000
committerTomás Carvalho <tomas@thetimesweeper.com>2023-12-30 15:30:53 +0000
commitd0773205a742fb4851c23e8c144c5775ea690020 (patch)
treeabeec5651635855065426f37672dcba1c272031f /dev-python/autoflake
parentmedia-video/obs-streamfx: fix outdated CMAKE variable (diff)
downloadguru-d0773205a742fb4851c23e8c144c5775ea690020.tar.gz
guru-d0773205a742fb4851c23e8c144c5775ea690020.tar.bz2
guru-d0773205a742fb4851c23e8c144c5775ea690020.zip
dev-python/autoflake: add 2.2.1, drop 1.4-r1
Signed-off-by: Tomás Carvalho <tomas@thetimesweeper.com>
Diffstat (limited to 'dev-python/autoflake')
-rw-r--r--dev-python/autoflake/Manifest2
-rw-r--r--dev-python/autoflake/autoflake-1.4-r1.ebuild27
-rw-r--r--dev-python/autoflake/autoflake-2.2.1.ebuild27
3 files changed, 28 insertions, 28 deletions
diff --git a/dev-python/autoflake/Manifest b/dev-python/autoflake/Manifest
index 488179638..2de21f6c2 100644
--- a/dev-python/autoflake/Manifest
+++ b/dev-python/autoflake/Manifest
@@ -1 +1 @@
-DIST autoflake-1.4.gh.tar.gz 24219 BLAKE2B 622c82b9ab5e7fd68e8bc2678c5868282e605640e1c52d1a8f81fbaaba26dfb738ac1ceb9eb20195bb820256fbae27222953a5271130e74b8708988516e20e00 SHA512 53e542a765cbd18df7c35a90f16786e173bdc332b4410abfbc6d24f1009bf5d6f8a383e897e72558617bdf339573d8aa9b8de6901aac392caf48889aacf0c9a6
+DIST autoflake-2.2.1.tar.gz 27377 BLAKE2B d669fd1954974f7237423d7dc67de044d737ba5a462b565f3307f1b6bdecefa6a6b2a6de437570e6a7772a692e894fb414e1ff05fc0aae7cbb3a0901ec9a0129 SHA512 02021b5f92edcdcb0b3c11132a46cf73dbc4b6e4efc4f5d5981b66bc5beafbef66a81229e65a727816ebda419c93399df14e9b6ba9f38a728f95a3455c1089f9
diff --git a/dev-python/autoflake/autoflake-1.4-r1.ebuild b/dev-python/autoflake/autoflake-1.4-r1.ebuild
deleted file mode 100644
index 901a3f140..000000000
--- a/dev-python/autoflake/autoflake-1.4-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Removes unused imports and unused variables as reported by pyflakes"
-HOMEPAGE="
- https://github.com/myint/autoflake
- https://pypi.org/project/autoflake/
-"
-SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND=">=dev-python/pyflakes-1.1.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests setup.py
-
-python_test() {
- "${EPYTHON}" test_autoflake.py || die
-}
diff --git a/dev-python/autoflake/autoflake-2.2.1.ebuild b/dev-python/autoflake/autoflake-2.2.1.ebuild
new file mode 100644
index 000000000..c3b7702a2
--- /dev/null
+++ b/dev-python/autoflake/autoflake-2.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..12} )
+DISTUTILS_USE_PEP517=hatchling
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Removes unused imports and unused variables from Python code"
+HOMEPAGE="https://github.com/PyCQA/autoflake/ https://pypi.org/project/autoflake/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/tomli-2.0.1
+ >=dev-python/pyflakes-3.0.0"
+
+#pypi tarbal does not include tests
+RESTRICT="test"
+
+src_prepare() {
+ eapply_user
+ sed -Ei -e '/include/,/]/ { /(test_.*|LICENSE|README)/d }' pyproject.toml || die "Sed failed :-("
+}