aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-04-28 14:37:54 +1200
committerTheo Anderson <telans@posteo.de>2021-04-28 14:37:54 +1200
commit983546f7b1702fb43dd0d2e5a393bc07d8f79fea (patch)
treeed2c2922776dba6609a00f93b552eb093daf0cee /dev-python/asyncpg
parentdev-python/anyio: add 3.0.0 (diff)
downloadguru-983546f7b1702fb43dd0d2e5a393bc07d8f79fea.tar.gz
guru-983546f7b1702fb43dd0d2e5a393bc07d8f79fea.tar.bz2
guru-983546f7b1702fb43dd0d2e5a393bc07d8f79fea.zip
dev-python/asyncpg: add 0.22.0
Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'dev-python/asyncpg')
-rw-r--r--dev-python/asyncpg/Manifest1
-rw-r--r--dev-python/asyncpg/asyncpg-0.22.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/asyncpg/Manifest b/dev-python/asyncpg/Manifest
index 4d5625d93..48b3903eb 100644
--- a/dev-python/asyncpg/Manifest
+++ b/dev-python/asyncpg/Manifest
@@ -1 +1,2 @@
DIST asyncpg-0.21.0.tar.gz 746782 BLAKE2B b3f149b02833b1206d82df0f3f28f6b24a8333b861f53410e053a36e4a68359e2c0641bbd9953040b74f1198c301b1a709052110275686a038c0febcb931e688 SHA512 8bfd6689008ea964ac66d1c141bddd749f50d928b6cbc5e059f0e1d0a3597213ccae0b2fa7d694bf4e40c0b2650c445d2c54040a076ba69509e508bf51de2970
+DIST asyncpg-0.22.0.tar.gz 770278 BLAKE2B 86943140bc03546d038889a52dca18eb932b77f09a4660971d3f31a93f114fd77f8e1094a96047ee37ec536b600989038701345ba88944bd5c5b455ada219fcd SHA512 b953290e10ea408ad67ac28f394bb3aaf84c4e42d136f0af9e2f7befcf03e34faf46ef1806c98099453028963142a6e3bce63ff3cbe118b2026744de2103eb37
diff --git a/dev-python/asyncpg/asyncpg-0.22.0.ebuild b/dev-python/asyncpg/asyncpg-0.22.0.ebuild
new file mode 100644
index 000000000..21455a2f9
--- /dev/null
+++ b/dev-python/asyncpg/asyncpg-0.22.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fast PostgreSQL Database Client Library for Python/asyncio."
+HOMEPAGE="https://github.com/MagicStack/asyncpg"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# ModuleNotFoundError: No module named 'asyncpg.protocol.protocol'
+# for some reason, still doesn't work if package is already installed
+# or with distutils_install_for_testing function
+RESTRICT="test"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/uvloop[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinxcontrib-asyncio dev-python/sphinx_rtd_theme