aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-23 22:30:44 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-10-24 03:49:59 +0500
commit847204a2b260d0e5783e3c84d6b7d0312e38cb81 (patch)
treef2197e4d9bd65fa5e005c17e0a2a763deb231fcb /dev-python/asyncpg
parentdev-lua/cqueues: fix restore ALL_LIBS (diff)
downloadguru-847204a2b260d0e5783e3c84d6b7d0312e38cb81.tar.gz
guru-847204a2b260d0e5783e3c84d6b7d0312e38cb81.tar.bz2
guru-847204a2b260d0e5783e3c84d6b7d0312e38cb81.zip
dev-python/asyncpg: fix build with USE=debug
Unset "cython_directives" via build_ext options, because the default for debug builds is broken. Closes: https://bugs.gentoo.org/926720 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/asyncpg')
-rw-r--r--dev-python/asyncpg/asyncpg-0.30.0.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-python/asyncpg/asyncpg-0.30.0.ebuild b/dev-python/asyncpg/asyncpg-0.30.0.ebuild
index a412dba36..f1897b83e 100644
--- a/dev-python/asyncpg/asyncpg-0.30.0.ebuild
+++ b/dev-python/asyncpg/asyncpg-0.30.0.ebuild
@@ -54,22 +54,27 @@ distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx-rtd-theme
-src_prepare() {
+python_prepare_all() {
+ # bug #926720
+ cat <<-EOF >> setup.cfg || die
+ [build_ext]
+ cython_always=True
+ cython_annotate=False
+ cython_directives=
+ EOF
+
# remove pre-generated Cython sources
rm asyncpg/{pgproto/pgproto,protocol/protocol}.c || die
- distutils-r1_src_prepare
+ distutils-r1_python_prepare_all
}
-src_configure() {
+python_configure_all() {
use debug && \
export ASYNCPG_DEBUG=1
- if ! use kerberos; then
+ use kerberos || \
EPYTEST_DESELECT+=( tests/test_connect.py::TestGssAuthentication )
- fi
-
- distutils-r1_src_configure
}
python_test() {