aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-18 18:02:21 +0100
committerAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-18 18:02:21 +0100
commit1c61b3463025826a323285cedf0f8d0941707a69 (patch)
tree4cf8be8ae860728fb584af4364eea953f5137a37 /dev-python/aiopg
parentdev-python/aiomysql: Restrict tests (diff)
downloadguru-1c61b3463025826a323285cedf0f8d0941707a69.tar.gz
guru-1c61b3463025826a323285cedf0f8d0941707a69.tar.bz2
guru-1c61b3463025826a323285cedf0f8d0941707a69.zip
dev-python/aiopg: enable docs
also tried and failed to fix tests Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Diffstat (limited to 'dev-python/aiopg')
-rw-r--r--dev-python/aiopg/Manifest2
-rw-r--r--dev-python/aiopg/aiopg-1.0.0.ebuild29
2 files changed, 17 insertions, 14 deletions
diff --git a/dev-python/aiopg/Manifest b/dev-python/aiopg/Manifest
index 641b3e01c..7465b6ef0 100644
--- a/dev-python/aiopg/Manifest
+++ b/dev-python/aiopg/Manifest
@@ -1 +1 @@
-DIST aiopg-1.0.0.tar.gz 31894 BLAKE2B d50f817cbf74e49ac48137744c90b58762ded28ba71bb35f7bdb14a80838159c4e78814e050ce23c9aa5c47a98c4ea254a40714e06cb2e6ace9aeefca3f0ae4e SHA512 59d360dbe270a39985aabcc926177f7c70a9a408998959f0d2a18c86f7b36f8aae01d42d8e99e2c11305dbc0d44b45e377c84c2e2e49b68a6b94995b1a3b3b98
+DIST aiopg-1.0.0.tar.gz 197879 BLAKE2B b2f434ff0b4fbd0de3065f04474aefeaacca3ef47635f2fdf0b0efe243eea32b9f45f4d532d698738ea7fb0fa7d45e18f2b5c276ec85a9e6859028ba686cdf3a SHA512 1947be779ad5f2a0a38a8db5318f52cf1245a24f1c73ec67453e3dfc9ec507dd5aaf95a079aabb18228ba230c71c58a072a5de48a9165ddebd82ac0207bc059b
diff --git a/dev-python/aiopg/aiopg-1.0.0.ebuild b/dev-python/aiopg/aiopg-1.0.0.ebuild
index 2e2c015c8..a74437fcd 100644
--- a/dev-python/aiopg/aiopg-1.0.0.ebuild
+++ b/dev-python/aiopg/aiopg-1.0.0.ebuild
@@ -9,29 +9,32 @@ inherit distutils-r1
DESCRIPTION="aiopg is a library for accessing a PostgreSQL database from the asyncio"
HOMEPAGE="
- https://aiopg.readthedocs.io
- https://github.com/aio-libs/aiopg
+ https://aiopg.readthedocs.io
+ https://github.com/aio-libs/aiopg
"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# tests seem to be wanting to send/recieve things
+# which is probably not allowed inside emerge so they fail?
+RESTRICT="test"
+
RDEPEND="dev-python/psycopg[${PYTHON_USEDEP}]"
-DEPEND="test? ( dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
- dev-python/isort[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}] )"
pkg_postinst() {
- optfeature "sqlalchemy support" dev-python/sqlalchemy
+ optfeature "sqlalchemy support" dev-python/sqlalchemy
}
distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinxcontrib-asyncio