aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-02 09:39:38 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-04 01:44:39 +0200
commitf3274781ea5286e04c79f1851a78eb8e11db7c53 (patch)
tree4e92d9aeb5106c3d0277ca4bc7257a3ce4ab31ea /dev-ml/js_of_ocaml
parentdev-ml/hex: initial import (diff)
downloadguru-f3274781ea5286e04c79f1851a78eb8e11db7c53.tar.gz
guru-f3274781ea5286e04c79f1851a78eb8e11db7c53.tar.bz2
guru-f3274781ea5286e04c79f1851a78eb8e11db7c53.zip
dev-ml/js_of_ocaml: initial import
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-ml/js_of_ocaml')
-rw-r--r--dev-ml/js_of_ocaml/Manifest1
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-4.0.0.ebuild37
-rw-r--r--dev-ml/js_of_ocaml/metadata.xml12
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/js_of_ocaml/Manifest b/dev-ml/js_of_ocaml/Manifest
new file mode 100644
index 000000000..b6e09e370
--- /dev/null
+++ b/dev-ml/js_of_ocaml/Manifest
@@ -0,0 +1 @@
+DIST js_of_ocaml-4.0.0.tar.gz 1477388 BLAKE2B 607496adfa192f92961adc2eeccf9dcd65d3c49eab8d60644197b4713608b320496fc9818d3b744de2ceb37c23af61662358824e6e1779281b5b140308960c50 SHA512 e46492a728fa315984257aebebe7c6a63dba48197674443a3c904f8e3a8aca67f68e43ec361e695ee93457c5d7cde81026c4ec1988bf7fc250ff1daddbd8e574
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-4.0.0.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-4.0.0.ebuild
new file mode 100644
index 000000000..4057ce3fc
--- /dev/null
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-4.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune findlib
+
+DESCRIPTION="A compiler from OCaml bytecode to javascript"
+HOMEPAGE="
+ http://ocsigen.org/js_of_ocaml/
+ https://github.com/ocsigen/js_of_ocaml
+"
+SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+IUSE="ocamlopt"
+
+RDEPEND="
+ dev-ml/cmdliner
+ dev-ml/lwt
+ dev-ml/menhir
+ dev-ml/ppxlib
+ dev-ml/ppx_expect
+ dev-ml/react
+ dev-ml/reactiveData
+ dev-ml/tyxml
+ dev-ml/yojson
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ for p in js_of_ocaml{,-compiler,-lwt,-ppx,-ppx_deriving_json,-toplevel,-tyxml} ; do
+ dune_src_install ${p}
+ done
+}
diff --git a/dev-ml/js_of_ocaml/metadata.xml b/dev-ml/js_of_ocaml/metadata.xml
new file mode 100644
index 000000000..b0fbe5f30
--- /dev/null
+++ b/dev-ml/js_of_ocaml/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <description>co-maintainers welcome</description>
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocsigen/js_of_ocaml</remote-id>
+ </upstream>
+</pkgmetadata>